Configuring Intel Graphics Card in 11.3


I recently installed 11.3 on my DELL netbook. After reading through the forums, including SDB:Configuring graphics cards and openSUSE Graphic Card Practical Theory Guide for Users, I don’t think my graphics card is being detected correctly. Please look at the data below to check my work, but I have an Intel card and the default fbdev driver is being used, allowing me only one nonoptimal screen resolution. My hope is to use a more appropriate (maybe the “intel”) driver and get my screen resolution to 1366x768, as it is in Windows XP. If you could point me in the right direction, I’d be very appreciative.

So far, I’ve created /etc/X11/xorg.conf in Level 3 and changed the Driver to “intel” as shown below, but I had to change it back to “fbdev” to get the GUI back.

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "ShadowFB"           	# <bool>]
        #Option     "Rotate"             	# <str>
        #Option     "intel"              	# <str>
        #Option     "debug"              	# <bool>]
	Identifier  "Card0"
	Driver      "intel"
	VendorName  "Intel Corporation"
	BoardName   "System Controller Hub (SCH Poulsbo) Graphics Controller"
	BusID       "PCI:0:2:0"

I separately tried to add the line ‘Driver “intel”’ to /etc/X11/xorg.conf.d/50-device.conf, but to no avail.

Section "Device"
  Identifier "Default Device"

  #Driver "radeon"
  Driver "intel"
  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"


Misc Information:

:~> xrandr
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768       76.0* 
:~> /sbin/lspci -nn
00:02.0 VGA compatible controller [0300]: Intel Corporation System Controller Hub (SCH Poulsbo) Graphics Controller [8086:8108] (rev 07)

Thanks again for your help! :slight_smile:

Did you try the driver intellegacy ?

openSUSE Graphic Card Practical Theory Guide for Users

Note if you still had the /etc/X11/xorg.conf file in place (with the fbdev driver selected) then the /etc/X11/xorg.conf/50-device.conf will be ignored.

I’m no expert in helping users tune their resolution when the automatic configuration fails to do so.

But my limited experience in watching this suggests that to understand WHY the appropriate resolution is NOT being obtained, one needs to look at a log file. … And in the case of X the log file is /var/log/Xorg.0.log.

Note such a file is TOO LONG to post here in this forum, so in a case like that, IF one wishes to show the log file, then the file contents should be copied, pasted and posted on a paste bin site such as SUSE Paste and then the website/URL address where the file content is pasted can be posted here and THAT website address is NOT too long.

Thanks again.

caf4926, I just tried intellegacy on both etc/X11/xorg.conf and /etc/X11/xorg.conf.d/50-device.conf, in different orders and found out what oldcpu just mentioned, that xorg.conf will be favored. Regardless, I wasn’t able to get out of Level 3 unless the driver being used was fbdev. (I did a quick ‘rpm -ql xorg-x11-driver-video-intel-legacy’ just to make sure I had it installed.)

oldcpu, Here’s the log var/log/Xorg.0.log

I have just looked at your Xorg.0.log and it clearly shows “fbdev” driver in use. From the Graphics Guide you may have noted the limitations of that driver, and supported resolutions is a big limitation. I doubt you will get anything better than 1024x768 out of “fbdev”. In fact the log shows it successfully probing your hardware for that resolution, as being valid.

Neither “intel” or “intellegacy” drivers appear to list/support your chipset. Google seems to indicate there has been nothing but problems for [8086:8108] with linux support, and other distros. :frowning:

Consused I think you are right. I’ve also read nothing very good about the Intel Poulsbo Graphics [8086:8108] and Linux.

The problem here is Intel contracted out the Linux driver coding to a 3rd party company, who made it proprietary. And they don’t keep the driver updated for all the various Linux distribution version updates. Ergo, support is poor.

Ug. So there might not be anything I can do? At least I asked for help before I spent a week going crazy over this. :wink:

From time to time you could google with search terms including e.g.: linux intel poulsbo 8086:8108. Pay particular attention to netbook specialist distros where there is more incentive to do something with niche drivers. There is hope because I think I saw bug reports for Debian and its derivatives.

Yes, it’s always a good move to share the problem here, otherwise frustration sets in. There’s always a chance someone may spot something useful and add it to the thread in future. Sorry, but thats about all I can suggest right now.

I don’t recall reading about the 3rd party coding, or the “proprietary” and support issues. Interesting, and on one of the search results I noticed Poulsbo chipset is also known as Intel GMA500.

Adding gma500 to my search, amongst other hits, was this page Poulsbo-ArchWiki. It makes interesting reading, and as I had read elsewhere that the “iegd” driver supported this chipset but not beyond xorg-xserver 1.6, the ArchWiki page confirms that limitation (i.e. kernel <= 2.6.31 & Xorg server <= 1.6).

@jricha13 Take a look at that ArchWiki page for background reading.

Its the ‘iegd’ driver: Intel® Embedded Design Center - Intel® Embedded Graphics Drivers (IEGD)

Great suggestion.
FYI, I have kernel 2.6.34 and Xorg 1.8. I am not interested in downgrading for the iegd driver, mostly because I might get way over my head.

Wondering if someone can look at this part of the Wiki: Poulsbo-ArchWiki | PSB/GMA500 Driver and let me know if I am safe to try it/if I need to do anything differently in openSUSE.

The final step: Cross fingers and restart X. is spot on.

I don’t see an easy solution for the psb-firmware load that would be needed for the psb approach. The last it was packaged for openSUSE was in the OBS for openSUSE-11.2:

Do you think the only fix would be to try iegd and downgrade my kernel a notch, or should I just wait it out for a few months and keep my eye on the lookout for better support?

It depends on

  • how unsatisfactory current behavior might be,
  • how willing you are to try different possibilities in the knowledge that you could end up doing a complete re-install of Linux to fix problems

IF it were me, and I was willing to explore, I would try to keep the latest kernel (which in effect rules out the IEGD driver as it requires a kernel that is 2.6.31 or older) and I would try to get someone to custom compile the PSB/GMA500 Driver for openSUSE. However in my experience this forum may not be the best place to get such help (although you could try).

I tend to be less willing to explore (ie less willing to compile my own driver if someone else more capable can compile the driver), and what I would do is boot to an 11.4 liveCD and confirm if this problem exists also in 11.4 (I suspect it does). Then I would write a bug report on openSUSE-11.3, and note the poor graphic support for poulsbo, also noting in the text of the bug report that this problem exists in 11.4 (based on the liveCD test). In the bug report I would point to [archlinux linux poulsbo wiki page](the . Unfortunately the bug report will likely be immediately closed, as that driver requires proprietary firmware and SuSE-GmbH will NOT package drivers that require proprietary firmware. Still , I see that as a pre-requisite 1st step.

Then next step, after raising the bug report (even though it won’t be actioned by SuSE-GmbH other than closing) I would then post on the packman mailing list and reference the bug report in my packman mailing list post and ask if a packman packager would package a driver for openSUSE-11.3 and for 11.4 with the [archlinux linux poulsbo page as a basis](the for any Packman package.

IF there was no response to that request (from the Packman packagers) within a week or two, I might then and only then try to custom compile this myself.

I will definitely look into your advice oldcpu. Thanks again for all your help everyone. If/when I find a solution I’ll make sure to post it here.