Configure the keyboard

I noticed that even if my keyboard works well, the special functions, like FN+f4/f5 (for managing light), aren’t supported. How can i solve this?

im guessing here from vague observations/experiences but i think these things are controlled at a lower level by kernel/firmware and are handled as acpi events?

  • IF so upgrading the kernel might help.
  • if your on kde you should be able to map shortcuts eg alt<F6> as a workaround. (i dont think mapping FN to DE shortcuts is possible)
  • if you look up acpi and fn keys you should find some pages that (claim to) allow you to map the acpi events yourself.

if non of this helps id suggest adding a lot more information (your machine brand/model and cpu?) so that people can make informed diagnosis.

Assuming that you’re using a GUI such as KDE or GNOME, check that, the GUI’s Hardware System Settings are showing the keyboard’s manufacturer, model and type.

If the GUI’s support for your keyboard is not complete then, you’ll have to add the additional functionality by using ‘xev’, and either ‘setxkbmap’ or ‘xmodmap’.

Further information is available in the Linux man pages and the following URLs: <>, <>, <>.