Configure Desktop seems not to work now

PS, regarding your repo list:
You should remove the “openSUSE:Tumbleweed” repo (#9), that’s not the official URL and you do have the standard one anyway.
And run “zypper dup” afterwards.

Actually that URL should just redirect to the standard one, but who knows… That might be the reason for your problems.

OK Removed #9 and zypper dup showed nothing to do.

Ran the zypper install command and rebooted but no deal still have problems.


rpm -qa | grep plasma
patterns-kde-kde_plasma-20170319-12.1.noarch
plasma-nm5-pptp-5.11.95-1.1.x86_64
plasma5-workspace-branding-openSUSE-15.0~git20180116T134836~c3ce1b2-1.1.noarch
plasma5-pa-lang-5.11.95-1.1.noarch
plasma5-workspace-5.11.95-1.1.x86_64
plasma-nm5-lang-5.11.95-1.1.noarch
plasma-framework-5.42.0-1.1.x86_64
plasma5-pa-5.11.95-1.1.x86_64
plasma5-pk-updates-0.3.1-2.1.x86_64
plasma-nm5-5.11.95-1.1.x86_64
plasma5-desktop-lang-5.11.95-1.1.noarch
plasma-framework-lang-5.42.0-1.1.noarch
plasma-theme-oxygen-17.08.3-3.1.x86_64
plasma-nm5-openvpn-5.11.95-1.1.x86_64
plasma-framework-private-5.42.0-1.1.x86_64
plasma5-desktop-5.11.95-1.1.x86_64
plasma-framework-components-5.42.0-1.1.x86_64
plasma5-addons-lang-5.11.95-1.1.noarch
plasma5-workspace-libs-5.11.95-1.1.x86_64
plasma5-addons-5.11.95-1.1.x86_64
plasma5-session-5.11.95-1.1.noarch
plasma5-pk-updates-lang-0.3.1-2.1.noarch
plasma5-workspace-lang-5.11.95-1.1.noarch
plasma-nm5-vpnc-5.11.95-1.1.x86_64
plasma5-integration-plugin-lang-5.11.95-1.1.noarch
plasma5-theme-openSUSE-15.0~git20180116T134836~c3ce1b2-1.1.noarch
plasma5-defaults-openSUSE-15.0~git20180116T134836~c3ce1b2-1.1.noarch
plasma5-integration-plugin-5.11.95-1.1.x86_64


Stuart

Hm, looks fine.
One thing, you could uninstall plasma-theme-oxygen, that’s for KDE4 and useless with Plasma5. But shouldn’t cause a problem if installed.

Sorry, no idea then currently.
Except running “rpm -Va”. (just a note: it is normal that this outputs quite some “noise”)

And kactivitymanagerd is 5.11.95 too?

Removed plasma-theme-oxygen and kactivitymanagerd is indeed 5.11.95. Still no change to issue. Running rpm -Va now.

Stuart

Interestingly I have just booted my laptop which has extra repos added to the base 42.3 Leap and I already have QT5, Frameworks and Applications and so it has 5.11.95 installed without this issue.

The rpm -Va completed but no messages about any plasma stuff anywhere.

Stuart

I guess if no one has any more suggestions a re-install will be in order. Does anyone have any suggestions for diagnostics before I do that, I guess since I seem to be the only one having this issue in TW it must have been a glitch somewhere!

Just to check it out I downloaded the latest ISO and installed it OK in a VM which proved to be fine as I expected.

Stuart

Well I did try a re-install but had problems. See https://forums.opensuse.org/showthread.php/529343-Unable-to-use-existing-partition-setup-for-re-install
so did an upgrade using the latest snapshot but it has not resolved the problem. Now the only ting left is a complete re-install wiping everything except my data partitions. However I have found that the HDD where I have my system installed has a SMART status of caution so I will replace it before doing this.

Stuart

Probably a good idea.
Hard disk errors can cause the strangest problems… (and of course also corrupt your precious data)

I have today installed a new HDD and actually installed openSUSE TW on it, the desktop options all work on that. Although I still have the old HDD in the PC so that I can move my data over and it will then be removed. Sadly it’s just out of warranty by about 1 month!

Stuart

A bit late now, but we got a bug report that kactivitymanagerd apparently crashes if libQt5Sql5-sqlite is not installed.
And even if it doesn’t crash, it probably won’t work properly without it.

This might just cause problems like in this thread.

Although, a “zypper dup” should have pulled it in if not installed, except if you disabled the installation of recommended packages in /etc/zypp/zypp.conf.

I still have the old system disk in my PC and can boot it (or at least try as its failing) so I will boot it later and see if that is installed.

Stuart

Wolfi that was not my problem, kactivitymanagerd was 5.11.95 and libQt5Sql was 5.10.0 which is exactly what I have on the new working system.

Stuart

Yeah, it probably would have made the desktop completely unresponsive, or not even starting (the latter happened when I removed kactivitymanagerd a few days ago, the desktop only came up when I moved it back).

Although, it might be triggerZ’s problem on Fedora with 5.9.5 (the older version might behave differently)… Or not.

I have the same problem. On my desktop pc it doesn’t work even with a new user. On my laptop it works flawless. Only difference Nvidia vs Intel drivers

You mean “Configure Desktop”?
Or Plasma itself (i.e. no panel)?

On my laptop it works flawless. Only difference Nvidia vs Intel drivers

Well, are you sure the nvidia driver is correctly installed and working?
In particular the OpenGL part…

I also have this problem

My desktop and wife’s laptop both exhibit this issue. My laptop seems to be functioning perfectly.

Which one? And on which distribution?

I still think that this must be related to kactivitymanagerd somehow.
So try to remove its database, i.e. delete (or rename) the folder ~/.local/share/kactivitymanagerd/ and see if it helps.
You might lose your application menu favorites though, and the list of recently used applications/files.

All running Tumbleweed. The 2 that are defective have the configure desktop issue along with the inability to add a panel. removing kactivitymanagerd makes no difference.

There is a crucial difference: The desktop and my wife’s laptop hadn’t had any updates applied prior to this one for at least 2 weeks. My laptop (the working one) gets zypper dup’ed every couple of days. I just say that incase there was a plasma5 patch that ran a migration script which was missing if you jumped that update (long shot). BTW my desktop is NVIDA and openGL works fine and my wife’s laptop is Intel which has openGL working also.

I just saw https://bugs.kde.org/show_bug.cgi?id=389297, which seems to be about exactly the same problem.

In short, it is (can be) caused by kpluginindex.json files (which contain a cache of installed add-ons) that cannot be read.
Additionally, kpackage 5.43 changed the file format (the files are compressed now) and cannot read older files anymore (which is a bug of course, but not specifically related to Plasma 5.12, which explains that triggerZ has it with 5.11.5).

So delete all kpluginindex.json files in all subfolders of ~/.local/share/plasma/ and everything should work again.

If it also affects a fresh user account, such files may be in /usr/share/plasma/, so check that too.
Apparently they get written system-wide if you run Plasma as root… (ever heard that you shouldn’t run a desktop/graphical session as root? :wink: )

In particular, it seems /usr/share/plasma/plasmoids/kpluginindex.json is causing this, so delete it if it exists.

This fixed it for me after much frustration after I lost the panel and was having to put raw widgets on the desktop which would keep disappearing on relogins