Configure desktop ISO date YYYY-MM-DD no longer available?

Back in 12.2 there was an option to use the ISO date format YYYY-MM-DD. It was in Configure Desktop > Regional Settings > Formats.

But in 42.1 that option appears to be gone.

Is there a way to change the settings for ISO date format?

Not yet unfortunately… Take a look at the KDE bug report relating to date/time formats.

https://bugs.kde.org/show_bug.cgi?id=340982

For me it is a show stopper.

I’m glad I’m not the only one. There’s something like an angry mob over at the bug site.

And I did not even join there. To afraid I will loose my temper.>:)

What I find rather disconcerting about the lack of support for ISO 8601 is the simple fact it’s an international standard.

OK, if it was some obscure locale that was missing, I could maybe accept that it’s taking a long time to fix…

I agree. ISO dates are better. File names that include the ISO date sort chronologically by the name. Other date formats do not.

And there would be less confusion if we stop using ambiguous formats for date and time. Like contracts that have mm/dd/yyyy being interpreted as dd/mm/yyyy. Nothing but ill feelings when that gets messed up.

And worse using …/…/… which can be a real mystery.

In fact the world learned nothing from the Y2K problem.

I really agree with you :slight_smile:
I don’t remember in this moment how I did but I get this…
http://paste.opensuse.org/view/download/2412963
international date and - separation…
I will investigate :slight_smile:

Hi!
I’m not sure if i understand the problem from the OP but I get very confused with different format as described in the tread as well. Yes it did exist in KDE4 if my memory still works, -but where is it needed to set in 42.1 - Plasma 5?

Lets see:
I have Swedish keyboard layout,
US Region,
Numbers, Time, Currency etc set as Swedish in regional settings/formats:

http://jodo.nu/pic//pic4/systemsettings%20plasma5.png

My digital clock in the panel at
the bottom: ISO date format:

http://jodo.nu/pic//pic4/date.png

Oh I had larger problems whit similar problems before when 42.1 refused to read Scandinavian (i e Sweden - Finland) characters and in some case deleted them from the system.

Again, maybe I misunderstood the tread, in that case mea culpa:shame:.
regards

The problem is not with the Digital Clock plasmoid, that (at least now) has the ability to display the date in ISO 8601 format.

What is wanted is the ability to set the Date/Time to use ISO 8601 format everywhere else, independently of the locale setting.

For example, I want to use en_GB formats generally, but ISO 8601 as the date/time format.

That’s true. And it’s even worse in the US. Here we buy soda by the liter and milk by the gallon. I’m like, cut it out, pick a date a year from now and say everything is going to be metric.

… and of course, if I bought a gallon of milk here in the UK… I’d have a different quantity to you rotfl!

We’ve been “going metric” since the early 70’s and still haven’t fully made it.

Perhaps the solution would be to create custom locales, like en_SE, finely tuned to personal tastes. However I did not find an easy way for this, as /usr/lib/locale only contains binary (compiled) files.

PS. By the way, is anybody able to configure the Digital clock widget to display seconds as well? All other options (Show date, Use 24-hour clock, Show local time zone) seem to work, but no seconds shown regardless of “Show seconds” and “Date format” preferences.

Yes, I think that had been put forward as a possible interim solution over on the bug report.

PS. By the way, is anybody able to configure the Digital clock widget to display seconds as well? All other options (Show date, Use 24-hour clock, Show local time zone) seem to work, but no seconds shown regardless of “Show seconds” and “Date format” preferences.

Displays seconds OK using KF 5.19.0 and Plasma 5.5.5

http://paste.opensuse.org/view/raw/f2815017

[quote="“tannington,post:15,topic:115405”]

Displays seconds OK using KF 5.19.0 and Plasma 5.5.5[/QUOTE]Looks like it depends on locale settings: with “No change” or “Default (C)” (either inherited from global locale setting or overridden specifically for time formatting), no seconds are ever displayed, regardless of user preference; when any other locale is chosen, seconds are displayed as expected. What a nonsense!

Looks like the digital clock implemented their own thing to customize the format… KDE though is still dragging their feet. This is ridiculous.

This bug was introduced when the 12/24 hrs option was added.

I fixed it nearly a month ago, it should work in Plasma 5.6.4 now (or in openSUSE since 5.6.3 already):
https://quickgit.kde.org/?p=plasma-workspace.git&a=commit&h=a7a22de14c360fa5c975e0bae30fc22e4cd7cc43

Not sure if we will do an update for Leap 42.1 (probably not for this alone, there hasn’t even been a bug report, neither in openSUSE’s nor KDE’s bugzilla…), but you can apply the patch yourself. The corresponding file (/usr//share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/DigitalClock.qml) is just a text file.