Computer turns off by itself, right before reaching the login screen

Hi,
I am running an OPENSUSE 13.1 64bit on 6 month old hp z820. After restarting my computer, I can not login any more; right before reaching the login screen my computer turns off by itself. since yesterday I have been tried every possible recovery or debug mod available at the grub menu. it is shutting down just before loading the login screen each time. please let me know if you need additional information.
Thanks for your help and time,
kolaleh

You say

… any more …

Does that mean that 13.1 functioned earlier? When yes, the big question is then of course, what did you change? Any software installs/upgrades, config changes?

And, as the login screen you expect is shown by the display manger, we like to know which one you use, or in different words, which desktop enviroonment do you use?

On 08/20/2014 11:06 AM, hcvv wrote:
>
> You say
>> … any more …
> Does that mean that 13.1 functioned earlier? When yes, the big question
> is then of course, what did you change? Any software installs/upgrades,
> config changes?
>
> And, as the login screen you expect is shown by the display manger, we
> like to know which one you use, or in different words, which desktop
> enviroonment do you use?

This sounds like the problem that I had with my former laptop. That was a
motherboard problem. The bootup time was just enough to cause the GPU to
overheat and the self-protect to kick in. You can test this by allowing the
computer to sit at the GRUB screen to see if it shuts off there. Alternatively,
you can boot the Live medium.

if you made no change in software recently then it has to be a hardware problem

On 2014-08-20 15:26 (GMT) kolaleh composed:

> I am running an OPENSUSE 13.1 64bit on 6 month old hp z820. After
> restarting my computer, I can not login any more; right before reaching
> the login screen my computer turns off by itself. since yesterday I have
> been tried every possible recovery or debug mod available at the grub
> menu. it is shutting down just before loading the login screen each
> time. please let me know if you need additional information.

What happens if you boot the installation media and run memtest an hour or
longer (at least one full pass)?

The wise are known for their understanding, and pleasant
words are persuasive.

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/

On 2014-08-20 18:35, Larry Finger wrote:
> You can test this by allowing the
> computer to sit at the GRUB screen to see if it shuts off there.

I have a doubt about this.

I noticed a few days back, on a virtual machine on vmplayer, that
sitting at that point the cpu load soared. This is not possible to see
on a real machine, because you can not run anything; but on a virtual
installation you can see the cpu load taken on the host by that virtual
machine - and when sitting on grub it is 100%, and when sitting on
something else it is nil.

Now, if this is true in a real machine, it would overheat.

But maybe it is false and it is just an vmplayer idiosyncrasy. I don’t know.

Another way for the OP to test is to boot to text mode instead. Or maybe
not, if the kernel is suspect… :-?


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

For me this sounds like you might have set “shutdown.target” or similar as the default target to boot to. (you wouldn’t be the first one…)

If you’re using grub2, try pressing the ‘e’ key on your keyboard at the boot menu, then search for the line starting with “linux”, and append ‘5’ to it.
Press ‘F10’ to boot.
With grub legacy, just type ‘5’ at the boot menu and press ‘Return’.

Does the system boot correctly then?
If yes, enter YaST->System->Services Manager and set the “Default System Target” to “graphical”.
This should fix it then.

Thanks for all replies,
It (machine) was fine up to two weeks ago. some body run a very long program using FSL in my computer with my permeation two weeks ago and after that everything was working funny until I found that I had only 2% left in my root or disk space. after a lot of cleanup in tmp and var/log my computer backs to normal. all applications woks fine. yesterday I just upgraded and restart the computer. and I could not login since then.
I use Kde.
I noticed a little heat .
I think the computer is fine. when I choose OPENSUSE(no advance mode) I can see the login screen for few seconds and then it turn off itself. if I use the advanced mode it turn off before the login screen.
is there any way that I can accesses to my data. please help.

Thank you for all of your helps
Kolaleh

I have grab 2 and I type 5 like that (_5)at the end of line started with Linux. the screen login stays a little more than before and then turns off. I also use the original kde login page: all black with something green at the right side
thank you,
kolaleh

What do you mean by “upgraded” Did you upgrade to a new version or did you just get updates.

So what video card and driver? There was a recent update to the NVIDIA driver

You can always get your data as long as the drive is functional. You may have to boot to a live DVD or USB thumb drive

just update

Still need to know something about you hardware ie video chip and driver used. If a video problem it is usually not that difficult to fix. Bu Ihave not seen one turn the machine off freeze it yes shut down no. Could be as Wolfi suggests so try his test.

On 2014-08-20 20:26, kolaleh wrote:

> my computer backs to normal. all applications woks fine. yesterday I
> just upgraded and restart the computer. and I could not login since
> then.

Upgraded to what?

> is there any way that I can accesses to my data. please help.

You should then try to boot a rescue live, be it from CD or from USB
stick. I suggest you try the openSUSE 13.1 XFCE rescue image you can
obtain from the opensuse.org download place.

If that crashes, you probably have a hardware issue. If it runs, then we
can look at things.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

The ‘_’ was a space (’ ') I hope?
Then this cannot be the issue, but it was worth a shot.

It sounds like your computer is overheating then (that it shuts down even earlier in recover mode might support this).
Try to cool it, with a ventilator or something. Does it work longer then?

Is the Power button sticking when you turn the computer on?

I had that problem with a desktop computer. The power button stuck sometimes and the power off timer would turn off the computer after some number of seconds (4 or 5 IIRC).

On 2014-08-20 20:46, kolaleh wrote:
>
> just update

And what repos do you have active, do you remember?

Have you tried yet to boot off a live Linux?


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Hi,
thanks for all replies and sorry for my late reply. I was away from my computer.

sometimes and during last week, when I was trying to open one of my application (trackvis), I received an error massage instead; related to the xlib ( xlib error an extension of GLX is missing at display). because of that last week I tried to add some xlib through the Yast only. I do not remember the name of them but YaSt did not show any conflict between them and existing lib. Any way it did not solve my problem. The rest of my application woks perfectly fine. that was the only changed that I had made between to restart. could it be a display problem after all? if there is how can I fix it. Right now I am running the Memtest and it is only 78% so far.

is it possible for me to access my computer through command line before login?

I did not try live Linux I don’t no how.

Kolaleh

If GLX is missing on your display, something is wrong with the graphics driver. So, again, what graphics card do you have?

You added some xlib? From where? If you didn’t add any repos for that, it should be compatible, unless you replaced the 64bit one with the 32bit lib e.g. (you should have gotten dependency conflicts in that case though… :wink: )

In any way the system should not shut down because of this.
Does it really shut down?
Or is only X crashing, dropping you to text mode?
Or maybe X is running and only shows a black screen?

is it possible for me to access my computer through command line before login?

Yes. Add “3” to the boot options, as you did before with “5”.
You should be able to login in text mode then.

Would be nice of you could post the file /var/log/Xorg.0.log, this might contain a clue why X is not working.

Thanks for all your helps. the computer finished 2 passes of memtest and after that I added 5 at the end of the Linux line in the grub page and then I was able to login.
below is the results of var/log/xorg.0.log:var/log # emacs Xorg.0.log
****Activating service name='org.a11y.Bus’
****Successfully activated service 'org.a11y.Bus’
****Activating service name='org.a11y.atspi.Registry’
****Successfully activated service 'org.a11y.atspi.Registry’
****SpiRegistry daemon is running with well-known name -org.a11y.atspi.Registry
****Xlib: extension"XEVIE" missing on display “:0”.
****Activating service name='org.gtk.vfs.Daemon’


******** (at-spi2-registryd:8199): WARNING : Failed to registerclient: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The nameorg.gnome.SessionManager was not provided by any .service files


******** (at-spi2-registryd:8199): WARNING : Unable to registerclient with session manager
****Successfully activated service 'org.gtk.vfs.Daemon’
****Activating service name='org.gnome.GConf’
******Successfully activated service ‘org.gnome.GConf’

Thank you,
Kolaleh**

So it worked this time?
Did you do something wrong the first time?

Normally you should not have to add “5” to the boot options.
Does your system still shut down when you don’t do it?

In that case, you should set the “Default System Target” correctly in YaST as I wrote before.

below is the results of var/log/xorg.0.log

You didn’t post the file, you posted the messages that emacs prints out to the terminal.

Upload the file to http://susepaste.org or similar and post a link.

But apparently your system is working now, isn’t it?

And that message about the missing XEvIE extension should not have any negative impact. XEvIE is only needed to intercept mouse and keyboard events, apparently needed for certain GNOME accessibility features. See here: http://freedesktop.org/wiki/Software/XEvIE/
Apparently it’s not enabled by default in openSUSE, and that page even says:

It has been suggested that this extension should not be used because it is broken and maintainerless.

So I wouldn’t worry about that.