Computer locks up after sitting idle

It always seems to happen around 11:00 pm. After a few hours of idle, I come to check email or something and find the computer locked up. I usually never shut off my computer. I run BOINC and so leave it crunching data while idle. However, recently, the computer locks up. The keyboard doesn’t respond and the mouse moves erratically, if at all, and it doesn’t respond to clicks. It sometimes disappears altogether. The hard drive is churning without stop. In the past, I had to hold the power button for a long time to shut it off so it would reboot and give me back control. The mouse and keyboard are usb.

I don’t know what process might be running to make the HD churn. If I type ps into the terminal, it responds that only bash and ps are running. I stopped running boinc but that did not solve the problem. In fact, boinc won’t start anymore. Is there a hidden process running? Is it indexing? Baloo has never worked right for me, so I thought that might running in the background but I can’t tell.

Please help me diagnose this problem

That is as expected. To see a list of all processes do

ps -A

One of the first things I do on a new install (of KDE) is kick Baloo into the long grass ! :wink:

You can check whether it’s running by using:

balooctl status

To disable it add:

Indexing-Enabled=false

to the “[Basic Settings]” section of “~/.config/baloofilerc”

or use System Settings -> Search -> File Search - and uncheck “Enable File Search”

Wow! That made a difference. Instead of 2 or 3 processes, there showed dozens and dozens. Chrome seemed to be using the most resources and something called nacl helper. The baloo check said it was idle but had indexed 1070 of 1074 files.

I left the computer on all night with BOINC running. It did not lock up. This makes me remember that it is around 11 pm that this problem arises. Is there anyway I can check to see what might be happening just around that time? For example, is there a way to get constant monitoring instead of entering ps and getting a static report?

top or htop

Until recently was experiencing a similar problem, even complete freezing requiring re-start.

Reading log, and using free decided problem was insufficient RAM leading to memory freezing.

Then installed extra RAM so far no repeat of this problem.

BTW now do check more often with free and ensure close no longer used applications, even log out, quicker.

Thanks to all for the info.

It’s almost 11:30 and things are running clear. top (but htop doesn’t run) shows boinc using the most cpu and chrome using the most memory. Interestingly, I set boinc to use a max of 50% of cpu, yet top shows it to be using 59%. I will have to check into that.

Free shows I’m using less than half the available memory and swap is using none. Of course, all of this is while I have no issues. I hope the freeze doesn’t come back, but if I can get enough control to run either top or free, I will have a better handle on what happened.

A final question: could I leave top running all the time?. I could run it in its own terminal or on a separate tab in the terminal I always have open. That way, I could observe what is happening even if the computer doesn’t respond to mouse or keyboard. I know I could leave top running, so the real question is should I?

I have been for well over a decade.

Don’t let it mislead you: linux - top command on multi core processor - Unix & Linux Stack Exchange

Thanks! My plan now is to run top each time I leave the computer alone whenever I expect to be away from it for awhile.

I had this problem on one PC. Probably unrelated to yours. I had to fiddle with CPU voltage and switching frequency. Probably the motherboard VRMs are getting old. It worked great under load. But after heavy usage, then sitting idle after about 5-10 minutes it would hard lock.

I ran top for a long while and, when nothing happened, I shut it off. Then I came back to the pc to find it locked up! I’m pretty sure it was baloo. I ran top again and found baloo was using 85-99% of the cpu and 40% or more of memory. I had a devil of a time shutting it off! Several posts on how to shut it off failed until I repeated them a number of times. For example, every time I gave it the kill command, it would come back as a new process with a new pid before I could get my hands off the keys!

balooctl status showed it indexed 1070 of 1074 files and was running. It never finished indexing the remaining four files and maybe that’s why it was misbehaving. balooctl monitor showed it was hung up trying to index stdoutdae.txt (typing that name from memory). The other 3 files that were not indexed had similar names. I saw references to “blacklisting” folders so they would not be indexed but not individual files. Anyway, I shut it off finally. Hope I don’t need it.

Did you turn it off in config desktop??

Not sure what this means. But, the thing that finally got it to stop running was

balooctl disable

The dialog box that comes up if you try to configure baloo graphically is essentially empty without any real options to control. I like the idea of having a good index, but baloo often just crashes on a reboot. Its a hassle, not a helper.

If you want to permanently switch of baloo indexing:

Add:

Indexing-Enabled=false

to the “[Basic Settings]” section of “~/.config/baloofilerc”

I like the idea of having a good index, but baloo often just crashes on a reboot. Its a hassle, not a helper.

Take a look at recoll (It’s in “KDE:Extra” http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Tumbleweed ) - Very configurable, and I’ve found it extremely reliable, been using it for several years now.

Thanks. I’ll check it out.