Computer is not turning off when i shut it down.

Hello Everybody

I have recently installed Opensuse 11.0,
When i turn of my computer through Opensuse 11.0 it won’t turn of the computer, instead the progress bar stops at the end.

This problem occurred in Windows Vista and Ubuntu 8.04 too.
In both OSes i resolved the issue by turning off WOL (Wake-On-Lan) in the respective OSes.

I disabled the WOL in Opensuse 11.0 too,
But still it not unloading my eth0 drivers at all.
That is preventing my computer from turning off :frowning:

In Windows Vista and Ubuntu 8.04 when i turn off my computer, Ethernet Link Led in my router would be turned off, reflecting that my etherrnet card is disconnected from the router, but in Opensuse 11.0 even after disabling WOL, unloading r8169 the led is not at all turning off,

The led is not turning off even while restarting the Network Service. :frowning:

Some more updates,
If i disable my ethernet controller in Windows Vista,
Ethernet Led in my router is turning off.
But what every i do in Opensuse 11.0 Ethernet Led in my router is not turning off :frowning:

In some earlier openSUSE releases, one could use the following as a boot code, and that would help when it came to shut down:

ACPI is not the issue,
ACPI and APIC both are enabled .
The problem is my ethernet controller is not turned of at any circumstance.

That prevents my computer from powering down.

Users who used acpi=force also had acpi enabled. … You miss the point. The point is with the correct setting, your Ethernet device will be forced off.

I’m not saying it will work, but what does it cost you to try? …

As you suggested, i tried adding acpi=force in the boot entry.
But still no go :frowning:

Should i file a bug report?

Sure … maybe take a look at your logs (under /var/log, and also “dmesg” ) , to see if there is any additional information you can offer that will go with the bug reports.

Have a look at for your networkcard. The r8169 has a few issues. I would paste the link but is not really accessible for me atm