Computer hangs when booting from CD/DVD

I have installed a new CD/DVD drive on my PC. It is working perfectly, except for one problem. My PC frequently hangs when trying to boot from a CD/DVD. For instance, if I use the Opensuse 11.0 DVD to boot up (I am sure that the DVD is okay), then after giving the message “Boot from CD”, it refuses to go ahead any further or accept any commands. I have to restart it to begin. At other times, it works perfectly, and once it boots up from the DVD, it runs perfectly. I have already been able to install from the DVD in this way, but still I want to go to the root of this problem, so that I am sure that my hardware is okay.

I am giving the details of my computer’s processor, motherboard and my new DVD drive here:

Processor: AMD Athlon™ 64 Processor 3000+
Motherboard: MSI K8MM-V

Thanks for going through my post. It would be great if someone could help!

The first thing to check is the hardware. Usually if there is a problem with the OS, you’ll see the symptom further into the process, for example, an error reading a file or the inability to mount what is on it. But with a bootable CD or DVD, the very first action is the bios transferring control to the boot sector that is on the media, nearly identical to the process of the bios booting from a floppy and very similar to the bios calling the MBR to boot a hard disk.

So when you see "Booting from CD . . . " and it hangs, that indicates that the bios is not finding the boot sector on the media, or that there is something wrong with the boot sector on the media. It is also possible for the optical drive and the media to have a sensitivity problem between them, i.e., that sector on the media may be borderline usable and/or the drive may be rather sensitive, the consequence of which is erratic read behavior. There have even been numerous instances where a drive is problematic with media burned on a different drive while fine with media burned on itself; so, if you still have the iso file, you might want to burn another DVD with the new drive and see if that makes a difference.

If you can, also trying using some other bootable media burned on another drive; you need to make multiple tests as the behavior can be erratic. Keep in mind that commercial CD/DVD media are produced with an entirely different and substantially more reliable process than burning with an optical drive, so testing with commercial media may not be useful.

And finally, of course, make sure that the controller and power cables are firmly secured, and that the drive is jumpered correctly. If you can, also try switching the cable connection. These are all common causes of erratic behavior.

Good luck.

Thanks a lot for your help. I tried all the steps that you had mentioned but they did not work. A few days back I was able to solve the problem, and it turned to be a rather minor one.

I just had to update the BIOS. My computer is three years old already and it had some problems reading from the CD/DVD. Somehow the problem cropped up only after installing the new drive, and updating the BIOS solved the problem.

Thanks once again for your help.

You’re welcome, although I wasn’t really helpful. I didn’t mention a bios update because, even though you had installed a new optical drive, very rarely is there a problem in the bios with it as the atapi interface is very mature. Bios bugs are surprisingly not all that uncommon, but one like this is. And of course, finding a bios update can be difficult to impossible if one has the typically purchased oem machine. Let alone the dangers of flashing. So, congratulations, job well done! Next time I’ll remember to include checking the bios (with all the appropriate caveats).