Computer freezes with Linux

Hi!

My computer freezes always after about 20-30 minutes of use. I have tried to
install different Linux distributions, both OpenSUSE KDE (current installation)
and Linux Mint (Cinnamon and Mate) and updated newest packages, but the
problem persists. When freeze happens, keyboard or mouse doesn’t work so I can’t shut down by any
other method than pushing the off button.

I have used Windows 7 for years and it never hanged. When I first tried Linux
on Virtual Box it was also without any problem.

Another thing I noticed is that the computer is more noisy (maybe a jarring or burring sound) with Linux than with
Windows. As I remember, this problem was also not when I tried Linux on
VirtualBox.

OS version:
Linux 3.7.10-1.16-desktop
openSUSE 12.3 (Dartmouth (x86_64)

My computer is a Packard Bell Imedia 16210 NC, Inter Core i3 Processor 530
@2.93GHz (4 processors)

Output of fdisk -l:

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0006750d

Device Boot Start End Blocks Id System
/dev/sda1 2048 4208639 2103296 82 Linux swap / Solaris
/dev/sda2 * 4208640 46153727 20972544 83 Linux
/dev/sda3 46153728 1953523711 953684992 83 Linux

Thanks!

Here the lines from /var/log/messages after latest freeze (at 21.48):

2013-09-26T21:30:01.554807+02:00 linux-ev0m /usr/sbin/cron[5334]: pam_unix(crond:session): session opened for user root by (uid=0)
2013-09-26T21:30:01.589724+02:00 linux-ev0m /USR/SBIN/CRON[5334]: pam_unix(crond:session): session closed for user root
2013-09-26T21:45:01.598408+02:00 linux-ev0m /usr/sbin/cron[5516]: pam_unix(crond:session): session opened for user root by (uid=0)
2013-09-26T21:45:01.629897+02:00 linux-ev0m /USR/SBIN/CRON[5516]: pam_unix(crond:session): session closed for user root
2013-09-26T21:48:08.554888+02:00 linux-ev0m kernel: 4924.184543] nouveau E PGRAPH][0000:01:00.0] vm flush timeout: engine 0
2013-09-26T21:48:10.557960+02:00 linux-ev0m kernel: 4926.182077] nouveau E PGRAPH][0000:01:00.0] vm flush timeout: engine 0
2013-09-26T21:48:12.558235+02:00 linux-ev0m kernel: 4928.176818] nouveau E PGRAPH][0000:01:00.0] vm flush timeout: engine 0
2013-09-26T21:48:12.558247+02:00 linux-ev0m kernel: 4928.176865] psmouse serio1: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.
2013-09-26T21:50:11.364927+02:00 linux-ev0m rsyslogd: [origin software=“rsyslogd” swVersion=“7.2.7” x-pid=“532” x-info=“http://www.rsyslog.com”] start
2013-09-26T21:50:11.365261+02:00 linux-ev0m systemd[1]: Started Collect Read-Ahead Data.
2013-09-26T21:50:11.365268+02:00 linux-ev0m kernel: 0.000000] Initializing cgroup subsys cpuset
2013-09-26T21:50:11.365302+02:00 linux-ev0m kernel: 0.000000] Initializing cgroup subsys cpu
2013-09-26T21:50:11.365303+02:00 linux-ev0m kernel: 0.000000] Linux version 3.7.10-1.16-desktop (geeko@buildhost) (gcc version 4.7.2 20130108 [gcc-4_7-branch $
2013-09-26T21:50:11.365304+02:00 linux-ev0m systemd[1]: Started Replay Read-Ahead Data.
2013-09-26T21:50:11.365308+02:00 linux-ev0m kernel: 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.7.10-1.16-desktop root=UUID=540d61ba-d05b-4a56-a822-d00$
2013-09-26T21:50:11.365309+02:00 linux-ev0m kernel: 0.000000] e820: BIOS-provided physical RAM map:
2013-09-26T21:50:11.365310+02:00 linux-ev0m kernel: 0.000000] BIOS-e820: [mem 0x0000000000000000-0x00000000000997ff] usable
2013-09-26T21:50:11.365311+02:00 linux-ev0m kernel: 0.000000] BIOS-e820: [mem 0x0000000000099800-0x000000000009ffff] reserved
2013-09-26T21:50:11.365312+02:00 linux-ev0m kernel: 0.000000] BIOS-e820: [mem 0x00000000000e0000-0x00000000000fffff] reserved
2013-09-26T21:50:11.365312+02:00 linux-ev0m kernel: 0.000000] BIOS-e820: [mem 0x0000000000100000-0x00000000bf77ffff] usable
2013-09-26T21:50:11.365312+02:00 linux-ev0m systemd[1]: Starting Load Kernel Modules…
2013-09-26T21:50:11.365314+02:00 linux-ev0m kernel: 0.000000] BIOS-e820: [mem 0x00000000bf780000-0x00000000bf78dfff] ACPI data
2013-09-26T21:50:11.365316+02:00 linux-ev0m kernel: 0.000000] BIOS-e820: [mem 0x00000000bf78e000-0x00000000bf7cffff] ACPI NVS
2013-09-26T21:50:11.365317+02:00 linux-ev0m kernel: 0.000000] BIOS-e820: [mem 0x00000000bf7d0000-0x00000000bf7dffff] reserved
2013-09-26T21:50:11.365317+02:00 linux-ev0m kernel: 0.000000] BIOS-e820: [mem 0x00000000bf7ed000-0x00000000bfffffff] reserved
2013-09-26T21:50:11.365318+02:00 linux-ev0m kernel: 0.000000] BIOS-e820: [mem 0x00000000fed20000-0x00000000fed3ffff] reserved
2013-09-26T21:50:11.365319+02:00 linux-ev0m kernel: 0.000000] BIOS-e820: [mem 0x00000000fee00000-0x00000000fee00fff] reserved
2013-09-26T21:50:11.365320+02:00 linux-ev0m kernel: 0.000000] BIOS-e820: [mem 0x00000000ffb00000-0x00000000ffffffff] reserved
2013-09-26T21:50:11.365316+02:00 linux-ev0m systemd[1]: Starting Setup Virtual Console…

Sounds like you have a very interesting issue there. When I first started reading
your post I was sure I was reading about a hardware issue, most likely a cooling
issue, but also you mentioned that you didn’t have any issues with Windows
or with Linux in a VM under Windows, and I began to doubt myself.

Then I read your description of a “jarring or burring sound”, a quite classic
description of the sound of a malfunctioning cooling fan.

I don’t have any definite answers for you, but I’ll bet you’re going to find that
you have a fan that needs service or replacement (CPU cooler maybe). It’s
not unusual to have a dirty or worn fan run fine at one speed but be really
noisy when running either faster or slower.

My best guess is that you’re going to find that Linux simply causes the fan to run
at a different speed than Windows does, and that is revealing an easily resolved
hardware issue. Sometimes a worn fan will cavitate. Maybe cavitation is causing
it to not cool sufficiently.

Suggestion:

  • clean the fans and any heat exchanger fins
  • check for fan blades that wobble
  • if any fan wobbles replace it

Thanks, I will try to clean the fans. Will it possibly fix the freeze problem. Anyone knows what these messages mean that seems to come when the computer hangs?

2013-09-26T21:48:08.554888+02:00 linux-ev0m kernel: 4924.184543] nouveau E PGRAPH][0000:01:00.0] vm flush timeout: engine 0
2013-09-26T21:48:10.557960+02:00 linux-ev0m kernel: 4926.182077] nouveau E PGRAPH][0000:01:00.0] vm flush timeout: engine 0
2013-09-26T21:48:12.558235+02:00 linux-ev0m kernel: 4928.176818] nouveau E PGRAPH][0000:01:00.0] vm flush timeout: engine 0
2013-09-26T21:48:12.558247+02:00 linux-ev0m kernel: 4928.176865] psmouse serio1: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.

On 2013-09-27 07:46, PeterDD wrote:

> Thanks, I will try to clean the fans. Will it possibly fix the freeze
> problem. Anyone knows what these messages mean that seems to come when
> the computer hangs?
>
> 2013-09-26T21:48:08.554888+02:00 linux-ev0m kernel: 4924.184543]
> nouveau E PGRAPH][0000:01:00.0] vm flush timeout: engine 0

Try with the proprietary nvidia driver.

NVIDIA
NVIDIA the hard
way
NVIDIA
drivers
Nvidia video cards
NVIDIA
troubleshooting


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

it dose sound like a nouveau driver issue

as in it is NOT running the fan on the card until it overheats

i had that issue on a nvdia GTS 240

using the current nvidia.run driver fixed that

Thanks. My NVIDIA is NVIDIA Corporation GT215 [GeForce GT 320], so I installed
by clicking on the last button in this page as you adviced (GeForce 4 and
older): https://en.opensuse.org/SDB:NVIDIA_drivers

I have only tested for a short while so I can’t say yet for sure if it is ok.

However the monitor resolution is now distorted. There
are black spaces both horizontally and vertically (image shrinked).

I tried to adjust on “Display settings”, but there is only one option for
“Size”: 1280x1024. But I think I need 1980x1080. How do I add other resolutions
than 1280x1024?

My understanding is that in cases where “Display settings” provide no more higher resolution options, then in order to provide more guidance, more information is needed. I believe the information that may help would be if you could open a konsole, and send the command:


xrandr

and then copy and paste here the output.

Also, please with a text editor open the file /var/log/Xorg.0.log and share its contents here. The best way to share the contents of such a large file is to copy the log file contents and paste it on the pastebin site SUSE Paste, and press contribute. That will give you a website location where the log file content is now stored, and please then copy the website location/url/address here in a post.

Our forum’s graphic resolution experts can then look at that output/content, and provide good recommendations on how you can possibly improve the resolution of your computer.

That’s the wrong one. That one is for GeForce 4 and older cards (as you write yourself) which are 10+ years old…
You need the latest G03 driver, the first one in the list.

So run this in a terminal window:

sudo zypper rm x11-video-nvidia nvidia-gfx-kmp-desktop
sudo zypper in x11-video-nvidiaG03 nvidia-gfxG03-kmp-desktop nvidia-computeG03

Or do the same in YaST->Software Management, i.e. uninstall the packages x11-video-nvidia nvidia-gfx-kmp-desktop (or any other nvidia-gfx-kmp-* you may have installed), click on “Accept”, then enter YaST->Software Management again and install x11-video-nvidiaG03, nvidia-gfxG03-kmp-desktop, and nvidia-computeG03.

After a reboot, your driver should work correctly.

Please install Mesa-demo-x and run this to verify:

glxinfo | grep render

Yes, I was in a hurry and since there were no hundred numbers I though 4 included 400 and below…

Anyway the resolution now is good when I typed these commands and restarted. The output of glxinfo | grep render:


~> glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: GeForce GT 320/PCIe/SSE2
    GL_NV_blend_square, GL_NV_conditional_render, GL_NV_copy_depth_to_color, 
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
    GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
~>

By the way, how concerned should I be about using proprietary drivers from NVIDIA? One reason for switching to Linux is I want to use free and secure software. Thank you.

Well the video drivers are just never going to be free as in speech. But they still supply a superior result in most cases and in some cases the OS drivers don’t work at all. So it is your choice. Un less you are a really true believer I’d not worry about it. Some times we need to compromise.

On 2013-09-29 17:46, PeterDD wrote:

> By the way, how concerned should I be about using proprietary drivers
> from NVIDIA? One reason for switching to Linux is I want to use free and
> secure software. Thank you.

For that, you would need to be careful about what hardware you buy: some
simply are not supported for several reasons, some are but the support
is incomplete (like nouveau). Choose your poison :-}

If the freezes stop, please report in a bugzilla this experience.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)