Computer "forgets" wireless password

After the install and firing up the computer I had to enter the wireless password. But now whenever I turn the computer on it asks again and does not connect until the password is entered. Normally on the other computers they not only remember the home WiFi password but also others (together with the SSID). Why is this? I have to say that I am on Ethernet as well but that should not make any difference.

What desktop environment are you using?

If it is KDE, there are three possibilities for the password:

  1. The password is saved in your KDE-wallet;

  2. The key is saved in a file readable only by root, but potentially available to all users depending on network settings;

  3. You can enter the key each time you connect.

It seems that you are using the third of those options. The first option is normally the default. I think the second option is default for Gnome and most other desktop environments.

Thank you, nrickert. Yes I use KDE and when I first entered the password (it is really long and I don’t want to do this every time) I had kde-wallet on. But KDE-wallet kept constantly asking after its password so i turned it off. Any idea how this can be fixed?

Right click on the network tray icon. Select “Network connection settings”.

Then select you WiFi network (might already be selected). Click on the “Wi-Fi security tab”.

You should be able to set where the key is kept. You want:
“Store password for all users (not encrypted)”. Hmm, the wording might be different. Here, I have it set so that all users (which are only me) can share the WiFi network.

That should be one of the choices available. You may be asked for the root password at some time while setting this. But, thereafter, it should all work.

There are two documents which are essential for setting up KWallet to perform properly:

  1. The ArchWiki article: <>.
  2. The KDE Documentation: <>.

Hi nrickert, I tried your method (now repeated at least 3 time:

I was never asked for the root password which I find strange. But neither reboot nor systemctl restart network connect to WiFI.

OK I think the problem is solved. As root from command line I opened systemsettings5 and entered the password. Thank you, everyone who chimed in to help!

Correct – the WLAN/WiFi password is a per-user “secret” which is normally stored in a user’s encrypted Password Wallet …

  • Network Manager is designed to connect to a WLAN/ WiFi Network on a per-user basis …

Which is wrong for 99% of users of this forum. There could be some enterprise customers with true per-user authentication, but I doubt they are actually using openSUSE.

In my KDE Wallet, there are more than a few stored passwords –

  • My access to the KDE Bug Reporting for Konqi.
  • My access to the various WLANs I connect to – which Network Manager uses to automatically connect to the WLAN I choose to connect to …
  • My access to my e-Mail accounts.
  • Plus noted identification and passwords for my Medical Insurance, Bank Accounts, this Forum, and so on and so on.

But then, I’m an extremely large corporation with a family sized number of users … :upside_down_face: