Computer Does Not Shut Down/Restart

Brand-new to Linux. Using a computer with openSUSE 11.3 (64-bit) freshly installed. Install went flawlessly without any kind of error messages.

Hardware used: MSI X58 Eclipse, Intel i7-920, 6 GB memory, Seagate 500 GB SATA.
openSUSE is the only OS installed.

After the install is finished, all programs work fine. HOWEVER when I try to shut down/restart the computer nothing happens! I basically have to use the power off button to shut down…

Any ideas what it could be and how to fix it?

Have you Updated?

Check this thread:
Problems w/ Opensuse 11.3 32bit shutting down and rebooting

Are you using kde or gnome?

If you logout (Assuming you have autologin disabled!)
What happens if you try shutdown/restart from the login screen?

I have Autologin enabled.

  1. No, I installed openSUSE 11.3 from scratch.
  2. I am using KDE (it was the default).
  3. I have Autologin enabled.

Open a terminal and become su -
To do that type: su - (then hit enter) and then type your password, don’t panic that nothing shows as you type, just do it and hit enter

Now type: zypper ref
when that is done type: zypper up
accept it’s requests

reboot when it’s done

You should, it’s better
Disable Auto-Login

Did as you instructed but nothing changed.
I installed the 32-bit version over the 64-bit one but still have the same problem.

Did you try as su -

shutdown -r now

That almost worked! Instead of shutting down the suggested command reboots my PC…

Try booting in Failsafe
Does your PC shutdown from there

No, nothing happens. Just like when I bootup using the Desktop option.

Now try

shutdown -h now

What graphics card is in there? I’ve had problems with Power Management that was tied to my graphics driver.

I had the problem, and I started the other post. “Problems w/ Opensuse 11.3 32bit shutting down and rebooting”. I finally got my machine to work by using both 64bit dvd and non oss cd. Reinstalled everything again. To include the 32 bit software on the disk. My machine with go through all the motions, but like the software fails to turn off the hardware. Well hope this helps.

That worked! I guess I am stuck with using this command, right?

The graphics card is an ATI Sappire HD 4850 512 MB GDDR3.

On 2010-10-03 18:06, tb75252 wrote:

> Did as you instructed but nothing changed.
> I installed the 32-bit version over the 64-bit one but still have the
> same problem.

Why would you think that reinstallation would solve the problem? This is not windows!


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

You could start a bug report
From there you may get help to solve the problem now or at least it will be fixed in future for your hardware:
https://bugzilla.novell.com/index.cgi

Done!

Thanks for all your help. I really appreciate it.

No problem
Hope things develop positively :wink:

OK - here’s the deal: in my case, installing the proprietary driver (Nvidia for me) fixed all my power management issues.

HOWEVER: there are numerous problems reported with the latest kernel update(s) if you have an ATI card, so only try that at your own risk - you may lose more than just being able to shut down the machine. Search in this forum for recent threads around the kernel update and ATI cards to see if you’re up to it.