Computer does not resume after going into sleep mode

I’m not sure where to post this, as I haven’t installed OpenSuse yet. This is something that occurred while I was trying a LiveCD of OpenSuse 11.0 (Gnome Edition) that I burned at 4X with Nero in XP (after making sure that the md5sum was correct).

I tried the sleep mode function on my wife’s laptop (Satellite A100), but had a hard time re-starting the computer after it went into sleep mode :(. I tried the Vulcan nerve pinch (ctrl-alt-del) to restart it, but nothing happened. I also tried ctrl-alt-backspace (twice in a row) to reload the desktop, but nothing happened. I then shutdown the computer using the power button, and restarted it only to get a black screen. I tried this several times, but always ended up with a black screen. The fan appeared to be working when I was trying to resume the computer, but to be quite frank, I did not pay too much attention to anything else at that point, as I thought I was a dead man for screwing she-who-must-be-obeyed’s computer! :wink: I then unplugged the power cord and removed the battery, pressed the start button (not sure if this was necessary, but I was just trying to clear all the residual power). I then re-plugged the battery and was able to properly start the computer. So I guess I’ll live another day! :smiley:

Interestingly, I tried this yesterday on my laptop (Thinkpad X60s), and both the sleep and hibernate modes worked properly on that computer.

I hope someone can explain to me what happened here :confused:. I am in the process of installing Linux on all my machines, but I want to make sure that I will not cause more problems than I solve. This looks like a great distro and appears to be relatively easy to use, and will be an interesting alternative to the OS that I am currently using on these machines (i.e. XP).


Hello Bassai,

there are many possibilities here. This is not enough information to give an answer.
Did you do “suspend to disk” or “suspend to ram”. These functions are implemented
by the “pm” package. Especially “suspend to ram” does not work on all computers.
This package has an log-file too. But if you used a button on the laptop, I
have not idea what could have went wrong. As far as I know, this invokes
a BIOS-function. I think that the “pm” package works better on computers than on