Compositing is not supported :[

I went to desktop effects to check it out and set it up…says its not supported on my system. Says required X extensions (Xcomposite and Xdamage) are not available. I used the livecd to install and im running openSUSE 11.1 kde4. I got a 9800m gts 1 gig and 4 gigs ddr3 ram in this laptop i would think that would support it. I read some other threads but i don’t really understand how to put in the command lines and all that. This is like the thrird time today ive asked for help im sorry to be such a bother. Thanks for helping me out so much.

I don’t quite understand the yast utility fully. Its just a downloader right? Should i just install everything i can off of there? Also my text is hella small. Makes it hard to read? If i rezise though the screen doesnt fit because i got a 17 in widescreen on this laptop. Anyways though i really just want the desktop effect. My rant is done.

Let’s start with the main topic. Yes your laptop is powerful enough to support pretty much anything. What compiz setup, when trying to activate is that your configuration is not done well. There’s not much you can do about it. If you go to Compiz Fusion - openSUSE it’ll ask you to makes sure several things are completed before installation. Just don’t mess up on the driver installation. DO NOT USE THE DRIVER GIVEN TO YOU FROM OPENSUSE.ORG . It might work for you, but it has caused so much trouble lately… YaST is not a downloader. It has a quite descriptive name, if you knew what it stands for. “Yet another Setup Tool”.It updates, validates, downloads, installs, and pretty much everything a user needs from a setup tool.

Installing everything off YaST? YaST itself does not store anything. It’s all online repositories used to download the source of the application. Install everything?! That would be the stupidest thing you’ve done in your entire life(probably). You don’t need all that. You’ll turn your laptop into a vast piece of chaos. You just simply do not want to do that. You need to install only … and only! what you need. Since you’re new automatic updates are probably turned on, which will keep you and your software up to date. Desktop effects seem really sweet, but I personally gave up on trying to fix … and most of the times hack things in order to get them working. No doubt - they’re a great feature of the linux desktop, makes it look incredibly attractive, but are not that “awesome”.

Good luck on trying to figure and configure them out.

//Alek

Thanks for the help. You saved me from jampacking my laptop with clutter. :smiley:

>< i can’t even install its. When i go to the link and click on the kde one click for compiz-fusion-kde i just get a small little blank box that pops up.

If you can’t use Kwin’s effects you won’t be able to use Compiz-Fusion’s effects. If you really want to use those effects you’ll either have to install the drivers from the Nvidia community repositories or the proprietary driver from the Nvidia website itself. Pick your poison :slight_smile:

I’m not at home with my nvidia card desktop but I’ll help out as much as I can.

Ian

Well the problem right now is when i click on a link to install from a site (any site/anything) a tiny square window pops up like its trying to download what i clicked on but its just blank. So i can’t even download anything from a site…/anger. So i can’t even go get a driver(i already have the one for the nvidia 6xxxx and up though).

Alright so did you get your drivers from the NVIDIA site or from the opensuse one click install or directly from the repositories?

I clicked install directly from the repositories off YaST. Do you know why any internet sites won’t let me download anything off of them though?

I can’t say that I do. Can you maybe post a screenshot of this?

have you used sax2 to detect your Nvidia card after you installed those drivers?

This is what happens when i go to download something
http://c4.ac-images.myspacecdn.com/images02/101/l_e9880cfd61334145aaa564563b22846b.png
When i click the link to dl that little window pops up empty and nothing happens.

Oh and have not used sax2.

Alright, have you tried accessing those sites using Konqueror?

To enable your Nvidia drivers you must run this in a terminal as root.

sax2 -r

Then restart your computer.

Good Luck,

Ian.

The terminal reads bash: sax2: command not found.

ps. i need to be able to use firefox because konquer isn’t supported by my schools website. Devry university. All my school work is on there. Im thinking i should just get the dvd and do a full reinstall because im running of the livecd right now.

You need to be root.

su

type root password

sax2 -r

Have you tried reinstalling firefox?

If all else fails and you really don’t want to go through all the trouble you can just reinstall. Let me know and I’ll help you once you’re done.

Good Luck,

Ian

Ha you saved me again. Its all up and running. The only thing now is i can’t set my monitor resolution any higher then 800x600.

Hmm… well, this time use the graphical interface of Sax2.

Go to Yast Control Center (Administrator Settings)

Then choose Hardware>Graphics Card and Monitor.

Manually select your monitor and then change the resolution to the resolution you want.

Also you’ll need to restart your computer for the changes to take effect.

Hope this helps!

Ian

Ha i did that right after i posted that last message. Everything is good now. :smiley: thanks again for all the help.

Cheers!

Glad everything’s working!

Hope the rest of the ride is smoother!

Ian

If you mean the text in YaST try running


kdesu qtconfig

And change it there - remember to save!