Compose key works only partially

Hello to all,

I am a new user here, though I am not new to Opensuse.

My recent install of 11.2/KDE on a laptop suffers from a strange misbehaviour of the compose key (I have declared the Windows and Menu keys as Compose). It appears that two different sets of composing sequences are active, depending on the application.

I have to explain that I use a lot of unusual characters on a regular basis and therefore keep adding more sequences to /usr/share/X11/locale/en_US.UTF-8/Compose. I have even redeclared a couple of predefined sequences to values that are more useful for me. All these work fine, for example in a terminal window (konsole or xterm) or in konqueror, or even in OpenOffice.

However, other applictions seam only able to handle the default set of Compose sequences. This applies, for example, to Firefox or Gimp. It does not matter whether they are invoked from the command line or from a desktop icon. I tried both the Firefox shipped with OpenSuse, and a download from Same result.

I tried to delete other Compose files from /usr/share/X11/locale/* but it did not help. I wonder where the default rules are actually found after deleting all the Compose files, even if (for some reason) the locales have changed in these applications.

Does anyone have an idea how to make it work?

Update: I met a few friendly openSUSE guys at the Linux-Tag in Berlin. It took them five minutes to listen o my bug report, figure out the trouble, google a cure and explain that to me.

The culprit is actually GTK+, which seems to have an own Compose table for all its applications, which is independent of the system Compose table. Therefore, all GTK+ compiled applications will ignore the locale-dependent system Compose table and default to an internal Compose table which appears to be identical to the one shipped with the English utf-8 locale.

Setting the envronment variable GTK_IM_MODULE to the value “xim” restores the wanted behaviour, i.e., the content of /usr/share/X11/locale/en_US.UTF-8/Compose will be honoured.

teach me (as i have NO idea what you mean by a “compose key”) please:

what happens when you push the “compose key” while (for example)
firefox has focus?


OpenOffice Writer?


DenverD (Linux Counter 282315)
posted via NNTP w/TBird | KDE 3.5.7 | openSUSE 10.3 SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio