I recently just installed OpenSUSE, and am very happy. My graphics, internet, and everything are working well. The only real thing right now that I can’t figure out is Compiz. Yesterday it was working fine, and today this is the error I get.

I just installed “Teeworlds”, but would that have done anything??

Please Help! :frowning:

Ok I restarted my computer, played Teeworlds, and Compiz suspended again, and I am not able to turn it back on. I should just remove Teeworlds? What is going on???

I use not much KDE and not openSUSE 11.3.
But maybe I could try to ask some questions to help you or a qualified helper?

Is Compiz now not running at all now? Or just disabled every time after you played your game?

Have you tried…

  1. …what your system said to you? “Check your X configuration. You may also consider changing advanced options, especially changing the composting type.”

  2. … to reduce the 3D-effects in Compiz?

  3. … to modify the effects/workarounds in Compiz/Advanced?

Maybe you would like to say something about your hardware especially about your graphic card?

Good luck

My 2 cents: You’re not running Compiz, but Kwin’s desktop effects instead. The config screen you see is for kwin.
Some games do “kill” the desktop effects, i.e. turn them off, or have settings that interfere with the desktop’s. One of the causes can be a crash of the game (even during shutdown). See what happens if you turn off the desktop effects, run the game, then reenable the desktop effects, i.e. compositing.

Thank you. Yes it runs perfectly fine without any glitches or bugs from what I can see. Yes, the Teeworlds did kill the compiz effects. I even tried turning off compiz, then playing the the game and exiting. I tried starting compiz again, and it did not work. I think the place I installed “Teeworlds” from was bad though. Also, I am using an ATI x700 Pro, but my friend gave me an Nvidia geforce 4 64g. Propably this weekend I will change the card.