Compiz with KDE4.6.1 and 11.4 - won't work for me

preamble - in 11.3 Compiz .8.x worked fine but not .9.x

In 11.4 “compiz --replace” displays no error messages, but starts up with no window decorations.

In ccsm window decorations, kde comparability, OpenGL and composting are all checked. Even tried as a different user after rm’ing the compiz-1 folder.

Composting using Kwin works fine.


SKIP_CHECKS=yes compiz --replace

See if that helps.

nope, but thanks

does it work for you?

fyi - GPU is Nvidia 9500gt running 270.xx series drivers self-compiled

I remember that on 11.3 I tried Compiz too and that I ran into a similar problem. And I seem to remember that solution had something to do with KDE’s desktop effects, especially those desktop effects that affect Window Decorations, such as Transparency.


Why do you prefer using compiz rather than kwin? a couple of years back I used compiz in kde but now I don’t have to, you will have better integration using kwin. Sorry for my question and no answer.

I’m still on 11.3 with kde unstable and couldn’t use emerald so I am running icewm for windows/decorations. Its a little spartan but fast like kwin has never been. I haven’t been able to get the compiz effects to run yet but think it might be something to do with the 270.30 driver? kde effects didn’t all work either. I notice a few anomolies but nothing major. Lancelot goes of the side of my screen slightly but it did that with Emerald using the Ghost theme too. To answer why not use kde effects for me kwin has been the primary reason.

I have the same problem! I used Compiz without any problem in openSUSE 11.3. But in 11.4 don’t work window decoration. I configured Compiz using this instruction. Now I think to install 11.3, configure compiz, switch on the Tumbleweed repository and make distr update. I don’t now how to use my lovely Linux OS without Compiz!

My idea has no success. May be it’s because of I’ve updated Compiz too. Now I want upgrade all the system except for Compiz.