Compiz window focus problem on openSUSE 11

Dear all,

once more, I need your help.
I have just installed openSUSE 11, it went well and worked fine. It even installed the nVidia drivers correctly (I see the logo at logon, can adjust settings, and so on).

I wanted to try Compiz, so I enabled it in KDE session manager and restarted. All the visual effects are working great, but I have a very annoying problem: essentially, when I click in a non-focused window, the window appears to get the focus. The window comes up, I can work in it, but as soon as I try to resize, close, or move it, then the focus moves back to the previous window. It tries to perform the action on the other window! It happens every time, for every window, when I try to perform an action using the window buttons or the border.
In order to actually pass the focus to another window, and be able to move , resize or close it, I have to click several times on the window title, and this is really unacceptable.

I looked in several forums in the Internet and in Google and apparently noone is having this problem. This is quite surprising, as my system is pretty clean (new openSUSE 11 installation with nVidia video card), and I did nothing but enabling Compiz.

Can you help me, please? Is there someone having the same problem?

Thanks

maTTeo

mtcerio,

From a terminal, launch ‘compizconfig-settings-manager’
and have a look at what plugins you have enabled.

You might wanna try to disable them all and enable them one by one to see
which is the culprit.

I run with Gnome and have never seen the problem you descibe with any of the
default plugins.


Niclas Ekstedt, CNA/CNE/CNS/CLS
Systems Engineer/NSC Sysop
Telindus Sweden AB

Niclas,

Thanks for the quick reply, good point. I tried, and it seems related with the “Window decorator” plugin. But I cannot disable it, because otherwise all the decorations disappear: no more title, border for resizing, buttons for magnify or close.

I checked in the advanced options of the plugin but there is nothing interesting, I think.

Any idea?

maTTeo

it seems related with the “Window decorator” plugin. But I cannot disable it, because otherwise all the decorations disappear: no more title, border for resizing, buttons for magnify or close.

You are on a wrong piste:
Windows decorator plugin is responsible to draw your windows’ borders. So the result is very normal.

Are you running on kde 4? I have used compiz since a long time and have never seen this bug. Since I haven’t really used suse 11.0 with kde 4, I think it’s a kde 4 related bug.

sefk,

Yes, I am running KDE 4. It’s the openSUSE 11.0 default, I did not change any setting/installation option.

maTTeo

mtcerio,

Well, could be related to KDE4 as well, one way to find out would be to
reinstall and select either KDE3.5 or Gnome instead.

Anyhow, you could try changing the Window Decorator, if that’s possible in
KDE. In Gnome one can select between the default GTK and the optional
Emerald Window Decorator.


Niclas Ekstedt, CNA/CNE/CNS/CLS
Systems Engineer/NSC Sysop
Telindus Sweden AB

Dear all,

I solved my problem by upgrading compiz to the latest version using the openSUSE X11:XGL repositories. From my point of view, I draw 2 conclusions now (which can be wrong, of course!):

  1. It was not a KDE problem, since I did not change any component of KDE. Rather, the problem was related to Compiz

  2. It is possibly a bug of the version of Compiz installed and supported by openSUSE 11.0.

Thank you very much for your support, I’m enjoying window effects!

maTTeo

I had the same. It’s one of the default settings for compiz-fusion in KDE4.
Forgot which one, either trail focus or fading windows, I use neither anyway.

mtcerio,

Glad to hear you solved it, thanks for the post back.
Sometimes the Buildservice repos, not only bring the latest and greatest but
actually fix stuff as well :wink:


Niclas Ekstedt, CNA/CNE/CNS/CLS
Systems Engineer/NSC Sysop
Telindus Sweden AB

I have just the same problem running SuSe 11.0 64-bit. Fresh install (and re-installed!). I’m running Compiz 0.7.4-31-x64_64 which (as far as I can tell) is the latest version I can see within repo_oss. Should I be looking somewhere else?

At the moment, the only workaround I’ve found is by right-clicking then left-clicking the title bar to really get focus!

Any help would be really appreciated. I can’t wait to show this off to my work colleagues, but they’ll laugh at my right/left clicking antics!

Exactly the same here, except that the right-click/left-click trick doesn’t work for me. Not consistently, anyway. I find that I have to double-click the titlebar to get true focus, and even that doesn’t always work. Sometimes I just have to keep clicking and clicking and clicking… eventually it comes through. Really annoying. But everything else in this version of compiz seems to work perfectly (current version as of this writing, compiz-kde4-0.7.4-31.2-x86_64 from OpenSuse Updates). Any more info is greatly appreciated.

…actually, I just updated to .2 from .1. I should restart KDE and see if it changes.

Read again: the problem was solved by updating to a version from the ‘X11 : XGL’-repository, which provides Compiz0.7.8, so you both should try that.

Index of /repositories/X11:/Compiz/openSUSE_11.0

Bingo!
Thanks for pointing that out (again). I missed it the first time because the site turned the OP text into an emoticon…

Anyway, I upgraded to 0.7.8, and at first it behaved very strangely. After restarting KDE/compiz it runs like a dream now. Danke.

on second thought, the 0.7.8 from the XGL repos is completely borked. Which packages did you guys install from there? All of them? After a reboot, I can’t even run kde at all. blank screen, artifacts, lockups, etc.

Did you install ‘compiz-manager’ as well? That is a start-script that will run Compiz no matter what - which is a disadvantage when you have to troubleshoot. Deinstall it and try starting compiz via ‘fusion-icon’ after KDE has started.

Of course one should never install all packages of a repository…

Since I use the git-Version of Compiz-Fusion, i can’t provide a list of needed packages (that would propably confuse you).

Well, I blew up my system beyond repair. YAsT freaked out and started installing all sorts of garbage that I didn’t ask it to. So now I am rethinking using that thing at all…

But anyway, prior to that, I tried doing one package at a time. I removed the manager script, but something else was still loading it up. Not sure what. Tried fusion-icon, that didn’t seem to work for me. At this point I forget what the issue was exactly. In any case, I am now making a complete backup before I try mucking with it again. I’ll probably go without compiz (again), because I switched from Slackware precisely so I could get away from all this monkeying around with different scripts and different sources, compiling this from source, installing that from a package… I just don’t have the time for that stuff anymore. but thanks again for your help. It’s appreciated.

I have OpenSuSE installed on two separate systems and had been experiencing this problem on both. One is 64-bit and one is 32-bit. Finally, I decided to search google and fix this problem instead of just disabling effects.

First I tried disabling trail focus and fading windows as suggested earlier. I could not find any trail focus and disabling fading windows did not help.

Next, I decided to update Compiz to the latest version which seems to have helped others. This worked for me! I’m not sure if I did it in the right or best way, but I’ll post how I did it so it might help someone else:

Go Into Yast -> Software -> Software Repositories
Add -> Community Repositories -> openSUSE BuildService - X11 : XGL

Go Into Yast -> Software -> Software Management
Search for ‘compiz’
right-click everything that’s checked and select update

Had to restart for it to take effect, but I’m sure there’s a quicker way without restarting everything.