Compiz window decoration troubles.

I used to use fedora and compiz fusion worked fine there on my hardware. I decided to give openSUSE a try and everything works great excepting the compiz. I have a very slow selection rectangle when selecting the desktop items and some nasty things happening to my window decorations. Here is the screenshot:](

I have the Geforce 8600M on my laptop. Thanx for any suggestions and sorry for my ugly English :wink:


Be sure to enable the Windows Decoration plugin in Compiz, using
the ‘compizconfig-settings-manager’

I assume you’re using the GTK Window Decorator, this really works best
with the OpenSuse 11 Gilloucge Theme. If you don’t like that, you can either
select another Theme in Gnome Control Center or switch to Emerald as your
Window Decorator.

Niclas Ekstedt, CNA/CNE/CNS/CLS
Systems Engineer/NSC Sysop
Telindus Sweden AB

I have had the same. There are two things you can do;

  1. in a terminal type: emerald --replace &
  2. start fusion icon or emerald and change to the window decoration of your choice
    For a more permanent solution do this:
  3. If you are using KDE go to ~/home/yourname/.kde and add a file like this:
#! /bin/sh
sleep 5
emerald --replace ccp &

This should start emerald when you start KDE.
Make sure you select compiz & emerald in the fusion -icon options.

Works fine for me :wink:

Window decorations plugin is enabled and I use gtk-window-decorator and want to set it up right somehow =)

Sorry for double posting. It’s forbidden to edit the mesage after 10 minutes from the time it was posted.
The thing is that I cannot find gtk-window-decorator config files anywhere in my home folder.

I have the same video card as you, i am using the emerald window decorator but it still looks very laggy. I have 256 mb of ram, nvidia, 3 gs of ram ddr2 and 2.0 core 2 duo. Any suggestions because this is way too laggy :frowning:

I’ve googled this stuff and the problem looks common. It seems that drvers are buggy. Maybe we should install another one from the nvidia off. site…

I have a geforce 8800 GTS card and a similar problem all the window borders in background windows (all windows apart from the foreground ‘live’ one) have missing window borders until I bring them to the front. I also have very slow scrolling but not sure if this is a related problem.

Same problem with a GeForce 8500 GT here. Using Emerald instead of Gtk Window Decorator ‘fixes’ the problem for me, except window shadows won’t show. Seams to be an NVIDIA specific driver issue other distros faced too.

Got a Ti4600 and everytime I enable desktop effects, my window decorations disappear. The plugin is enabled in CCSM so its not that. Ubuntu Hardy had the same problem and it turned out to be a line of code the user had to add to the xorg.conf but it was fixed before Hardy went final.

same problem here: Nvidia 128Mb 8400M GS

Also window animations (burn, explode, etc) perform really badly so I had to turn them off, everything else is fine (cube, etc)


I was having similar Problems try here:
Compiz Troubleshooting - openSUSE

Particularly the bit about Emerald decorator not working

Emerald decorator does not work

Even after setting ccsm → decoration → commandline to emerald --replace if it does not launch on startup run the following in shell as normal user:

echo “USE_EMERALD=yes” >> ~/.config/compiz/compiz-manager

Thanks for your reply, this fixed my emerald problems :slight_smile:

It works now! Everything is fine after the nvidia driver update!

Yep just got the Nvidia driver update and everything looks great. Very happy :smiley:

yes, this was a driver issue, i had this nice borders too, and they are gone with the driver update to 173.14.09

How did you guys get the new driver?

Was it through system updates and the Nvidia repo or did you download manually?


Yep. Just regular updates and nvidia repo


I have a Quadro FX 570M adapter in my laptop.
Initially during RC1 I downloaded the driver directly off
the Nvidia site, but once 11.0 shipped and the nvidia packages
were available through the repos. I installed that instead.

Niclas Ekstedt, CNA/CNE/CNS/CLS
Systems Engineer/NSC Sysop
Telindus Sweden AB

I got some updates today, but no new Nvidia driver. Will there be a new one for Ti4600 (legacy)?