Compiz suddenly quits with segfault error

New install of OpenSUSE 11.1 64bit on Intel Core2Duo E8400 and with Geforce 8800. Compiz seemed to work initially. For some reason it quits and prints the following error to the system log:

compiz[3578]: segfault at 579a ip 00007fecb4f27820 sp 00007fffc5e0cd80 error 4 in[7fecb4f24000+6000]

This seems to happen at random intervals. I can go back and restart it from the “Desktop Effects” menu, but if it happens when it’s performing an animation it sort of freezes X and I have to reset my system, though the cursor is still responsive and anything else going on seems to continue going on (for instance music keeps playing). I really like my eyecandy, so any help would be appreciated.

Bump. Filler. I hope this is allowed. If a mod or admin is going to delete this, please just delete this message and not the thread.

Same problem here,

compiz[4910]: segfault at 5c9 ip b79d395a sp bfdf50c0 error 4 in[b79d0000+5000]
compiz[13007]: segfault at 10 ip b7ad194e sp bf8f33d0 error 4 in[b7ace000+5000]

I found out that if I disconect my Internet connection I have less problems with it.

I use a ATI card: ATI Technologies Inc M71 [Mobility Radeon X2100]

And the ati drivers from

I hope some one will find the fix for this.

Thanx from me if you do.

Your graphic card driver might not be set up properly - thats why you get the segfault error.

For a better experience of Compiz Fusion I strongly recommend to use the right NVIDIA drivers.
You might want to consider uninstalling your current drivers and follow the exact instructions from Compiz - openSUSE :wink:


i also get the same error… it happens to me ONLY when im using any openoffice applications (which i use a lot) and it makes it practically unusable with compiz… tried to submit a bug report but got no answer…

After more testing I agree what innovamanager says openoffice applications lets the compiz lib crash.

Is there a way to help narrowing this problem so we can really help finding the solution.

I recently updated compiz packages and still got same problem… to be honest I dont know where to start looking to get more information about the problem :confused:

FOUND A FIX!!! rotfl!

  1. uninstall all your compiz packages
  2. delete your actual compiz repository
  3. install this compiz

Enjoy it!