compiz not working after kernel recompile

Dear All

I have recompiled my kernel and optimized it for the core2 CPU and increased the timer speed to 1000 Hz.
These two were the only options that I have changed from the default config that you have in the boot partition after installation and official updates.

Before recompiling the kernel I activated the desktop effects from the simplified compiz manager (under kde, keeping kwin as a window decorator) and everything worked flawlessly.

After recompiling the kernel and reinstalling the nvidia drivers either from the suse repository or compiling the driver from source, hardware acceleration works perfectly (6000 fps on glxgears), but composite effects do not work anymore.

When desktop effects are activated the window borders disappear.

I tried to give the usual options to enable native composite on nvidia cards as suggested by the suse wiki but the problem persists.

However the problem persists also if i switch back to the old default kernel and modules. Plus even reinstalling the nvidia drivers.

Can anybody help please?

Thanks a lot

You may need to recompile the video driver again. It worked for me once.


in fact that is what I did
i recompiled the video driver after recompiling the kernel
recently i have installed an unpdate of the compiz packages
now when desktop effects are enabled the window borders do not disappear, there is no crash but also…
nothing happens

i guess it was a bug in compiz somehow
in fact i did an additional update of the packages just a few minutes ago and now everything works perfectly
now I am really happy with my suse 64 bit

I think, you gotta recompile your Graphic Driver First.

I had this issue recently when I updated the compiz packages.

After googling I found the solution was to remove the ~/.config/compiz directory then re-enable with the compiz configuration utility.