Compiz lost konfiguration after restart

Hallo @all,

after Compiz is slow on my Desktop PC, i installed Linux on my Notebook with a better Graphicscard.
It works fine, but when i restart the notebook i have to enable Desktop Effects again. Why compiz disable Desktop effects after restart ???

Thanks a ton in Advance!

have you switched compiz to your default window manager?

I don’t know. Where can i do that ? With Yast2 ?


in yast get to the /etc/sysconfig editor, it’s been a while since i did it (and don’t use compiz any more) but there is a line which says something along the lines of ‘default window manager’ if using kde it will be set to kwin i believe, change this to compiz and it should work again after logout/login or reboot. if not post back and see what i can remember, i had the same problem but i got it fixed :slight_smile:

In openSUSE 11 and kde 3.x, you can create the file in /home/user/.kde/Autostart. The file may look like this:

sleep 5
compiz-manager --replace

or go to yast>system>/etc/systemconfig editor>desktop>window manager>default_wm

change to compiz. but the above post should work just as well.

Is there anywhere in that editor to set the default resolution to boot up with on a desktop pc? (not a laptop) The page in the kde control center intended for that is non functional in my system due to some randr incompatibility.

have you tried configuring sax2?

Hi I just tried this change to compiz, now my screen is blank when I reboot.

I tried automatic repair of dvd to no avail.

Can someone help me? What else can I try to return my dekstop default?


since this is your first post on this thead…do you have compiz installed? if you don’t then of course it won’t load the right window manager. what screen do you get after you log in? is it completely blank or is it a text log in?


Don’t mean to hijack this thread,

I do have the same setup, Compiz works until reboot, I was just trying to get it enabled on startup, like the original poster.

All I have now is black screen, with my mouse pointer moving around on it, no text.



I also get the graphical effects disabled after shutting down. After hearing what happened to Heeter, though, I’m reluctant to try tweaking anything just yet.

I also have a very strange problem with moving windows and I’d like to ask if anyone thinks the two problems are related.

The second problem I have is that when I move a non-maximized window and then release it to leave it in place, I’m unable to properly release from that window. Clicking anywhere outside of the window’s content causes the resizing action to happen. Even if I click on the title-bar of another window entirely, the mouse pointer icon for resizing the windows comes up. If I keep the mous button pressed, then I can move the mouse pointer to resize the window as if I had grabbed the edges of the window. Even though my mouse pointer is actually nowhere near the window it’s stuck to.

Clicking on the maximize button of the window I get stuck to has the same effect too. It just starts the window resizing action. The only way I have found that I can properly switch to other windows and reactivate the minimize, maximize and close buttons of a window is to double click the title-bar of the window I’m stuck to which causes the window to collapse to leave only the title-bar visible. I can double click it again to restore the size of the window and use the buttons as normal once again.

I don’t mean to drag this thread off topic; I’m also very interested in a satisfactory solution to the problem that this thread is about. I was just wondering if anyone that knows a heck of a lot more about this stuff than I do thinks the two problems are related?

Oh and I’m on KDE 4, by the way. The one that comes in the distro. Not one I’ve installed myself.

I to followed this thread and went to yast>system>/etc/systemconfig editor>desktop>window manager>default_wm and changed it to compiz and now i have a black screen on boot no text just a black screen.

I would realy like to know how to log back into the GUI.

Thanks in advance

hmmm this is strange. this worked for me in suse 10.3. anyway, do you both have any other DE’s installed? if so i guess you could open up another environment, eg gnome, go into sysconfig editor there and change it back…

what happens when you try to open a terminal? ctrl+alt+f7 is one way i believe…

Thats what Ive just done, started in safe mode (suse equivalent)then chose KDE3 as my boot option then went into yast>system>/etc/systemconfig editor>desktop>window manager>default_wm and changed it back to default_wm.

How did you start in “safe Mode”?

All I got is regular, and failsafe, but in failsafe, I get just text login, nothing else.

Please help, Thanks,


When i boot the laptop i have these options

Open Suse 11 (kernel No)
Failsafe–Open Suse (kernel No)

Open Suse 11 (kernel No) pae
Failsafe–Open Suse (kernel No) pae

I just chose Failsafe–Open Suse option with the pae at the end of it, (dont know why i have the later two options but both seem to work)and i got strait into the gui and changed it back to boot default_wm.

Hope that helps

For Opensuse 11.00: Please try Personal Settings > KDE Components > Session Manager > Window Manager > (Drop down list) Compiz.

Then restart KDE (Log-out, Log-in).

If you want to have the default window manager, select Kwin (KDE default) from the drop-down list. This is for KDE 3.5.9.

I assume that the 3D graphics driver is working in your system.

Let me know if this works for you.

Thank-you, this worked for me.

I Just want to point out that the Session Manager is in the Advanced User Settings section of the Personal Settings (Suse 11.0, KDE4).