Compiz in KDE 4.2 disaster :-((

Hi,

Today I upgraded Gnome 2.24 to 2.26 on opensuse 11.1 and for once in my life I now have a decent working gnome system. I logged in, got my sound (which didn’t work at all with the stock version from the suse dvd) and compiz was automatically activated. I was able to configure it further with the compiz desktop manager tool to my taste and I loved it. So far, so good.

But I also use KDE 4.2 on this pc but with KWin as compositing window manager, not compiz. So I logged out from gnome and started KDE 4.2. Disaster.

Compiz works fine but all of a sudden, and it can happen at any time at any action it stops working, transparant windows become black, I loose my titlebar, keyboard stops working and the compositing window manager reverts to a 2D system.

No such issues seen yet in gnome 2.26 though. It’s only in KDE.

The problem is that I was happy with KWin before but now each time I start KDE it loads compiz and I can’t turn it off and go back to KWin.

Also the fusion-icon is not working for this reason :

  • Error: the “FusionIcon” module is missing. If you did not install fusion-icon to /usr, you may need to add the appropriate site-packages directory to your PYTHONPATH

The file is located here : /usr/bin/fusion-icon /usr/bin/X11/fusion-icon

I don’t know what this means or how I can fix it. I know that this systray tool allows me to select a windowmanager as well as a theme because the theme it now uses in gnome is one without to top right buttons on the title bar to close, maximize and minimize. I see the mouse popup telling me what it is, I can click on it, it’ll work, but there is just no button visible. It’s very hard to minimize a window or close it. I always have to go via the taskbar…

So my question, how do I get fusion-icon to work and the most important question, how can I prevent compiz to load when I start KDE so it only runs in gnome ?
There is no shortcut in the KDE autostart folder and in the Autostart settings from KDE4 ??

Thanks

Hi,

The setting you’re looking for resides in Application Launcher (K or green openSUSE lizzard)>Applications>Configure Desktop (Personal Settings)>Default Applications (under Personal)>Window Manager. Choose Use the default KDE window manager (Kwin).

Not sure about using compiz in both KDE and Gnome as I only use KDE. You don’t really nee the fusion-icon as long as you choose the correct settings from the CCSM.

Hope this helps!

Ian