Compiz hell ? Need help


Previously I had Compiz installed that came from the Compiz repository that yast proposed me. With this one installed I was able to use Compiz with all it’s glory in Gnome but I had no window control buttons visible in the top right corner.
But in KDE this Compiz version was no more than a real disaster. Crashed constantly and the fusion-icon was not functioning.

After some reading I came to the conclusion that there are several repositories for Compiz (the one proposed by yast, then a couple on FTP server) etc…

I tried one of those but this is even worse. It starts compiz but never uses compositing, only 2D and I have no windows decorators (so no buttons and unable to move windows). Whatever I do, nothing works. I started fusion-icon to reload the compiz window manager, set emerald as decorator but nothing happens. When I switch to another decorator being GTK or KDE nothing happens.

So clearly this version of compiz sucks even more.

So my question, does anyone have a decent working Compiz version on KDE 4.2 and Gnome 2.26 that works, that has window decorations which can be changed with the emerald theme manager and not crashing in KDE, all of this for opensuse 11.1 on NVIDIA (btw, the previous verion worked more of less and KWin compositing effects works as well, so it’s not a driver issue).

If yes, please let me know where I can find a correct repository for this compiz version coz I already lost several useless hours of trying and screwing up my system and it takes me 30 minutes to restore my system image each time I screw it up on top of the exhausting reseach.

Many thanks.


First, you must remove all your compiz packages.

Then you need to reinstall from the one-click installer here:

Compiz Fusion - openSUSE

You don’t need the fusion-icon (as far as my experience it doesn’t download anyways). When you get compiz installed open the CompizConfig Settings Manager (CCSM) and find the Effects category. Put a check next to Window Decoration. Then click into Window Decoration and find command. Erase what’s in there and then add this:

emerald --replace

This will allow emerald to work without the fusion-icon.

Also, if there is nothing checked yet make sure, under Window Management section, you have Move Window, Resize Window, Place Windows, and one of the switchers selected (to be able to use the Alt+tab functionality). Also put a check next to Window Rules and next to above type


so youtube videos and other videos that are fullscreen cover the panel.

Good Luck,



Thanks for the information. I removed all the previous stuff, that’s something I learned in the past :slight_smile:

I’ll check it out tomorrow evening and let you know if I could get it running.

Thanks in advance

OK, I removed everything, installed compiz and emerald + themes from the one click installer (only the gnome button) and set up the compiz system with simple ccsm.
Then I noticed that the fusion icon was launched as well in muy gnome 2.26. So I opened the compiz settings manager and activated and configured some additional plugins.

They all worked fine, the decorator is emerald (but set as auto in the config manager) and up until now no single crash or lockup seen so far. Working like a charm.

Logged out from gnome, started KDE 4.2 and deactivated KWin and launched compiz via the simple ccsm tool. I imported the config that I exported in the compiz config manager in gnome right into KDE so I now have both settings in the two desktop environments.

In KDE it’s working just fine as well now.

Thanks for the great tip !!
To all of you having issues getting compiz up without the missing decorator or invisible window control buttons, just follow these tips here, and you’ll get it working just fine !!

Great to see you have it working! There’s just one last thing.

When you use Compiz-Fusion in KDE4, unless you specify, you’ll lose the capability to use the Print Screen button for Ksnapshot. You’ll also lose the ability to use Alt+F2 to use Krunner.

(I’m using Comipz-git right now so it’s hard to remember exactly what everything’s called) To fix this open up CCSM, then find the Commands plugin. Click into it and there should be a tab for Commands. For Command Line 0 type


Then for Command Line 1 type

Ksnapshot --current

Then under Key bindings set Run Command 0 as Alt+F2 and then set Run Command 1 as your print screen button.

Take Care,


Thanks for the tip, I’ll modify this tonight.

About the KSnapshot, it’s not really a problem. I use the Snapshot feature from Compiz instead.

Well you see, Compiz uses your own snapshot programs to take snapshots. I guess if you have the gnome snapshot program it’ll work. I don’t know as I only have KDE installed. But unless you specify your snapshot program, it’ll try to use gnome’s (I think that’s the default). If you can’t use gnome’s in KDE then that’s what you’ll have to do to get the snapshot feature.

Good Luck,


What are you talking about?? I’m launching krunner using Alt+F2 with no problems using Compiz version 0.8.2.

Just checked out of curiosity and making a snapshot with PrintScreen works like a charm too so i don’t understand where are all your problems coming :)??

Repo i’m is this one,

It’s been announced on

So that’s without those settings being set in compiz?

I just know I had to manually add them on a fresh install of openSUSE. I didn’t have any problems when upgrading though, or when switching between the newest and the compiz-git versions.


Without changing anything. Installed Compiz 0.8.2 on a fresh 4.2.2 install and voila. Krunner and ksnapshot working out of the box you might say :slight_smile:

And boy, it is A LOT faster than the 0.7.8.

Hmmm… Maybe my computer just doesn’t like me? :\

Well that’s good you don’t have to change anything anymore. Thanks for the information :wink:

Yes it is a lot faster. I wish I had the graphics cards to show off all the effects though :’(

The git version has some of the speed upgrades as well. It’s marked as version 0.7.9.

In any case, I guess no other modifications are needed. So have fun with Compiz-Fusion and openSUSE!


Well, ALT+F2 doesn’t do anything on my opensuse 11.1 with htis version of compiz. I don’t know who’s right or wrong but it doesn’t work for me and I don’t care :smiley:

You didn’t specify with which version it doesn’t work with you.

I personally had no problems at all when using Compiz 0.8.2.

I am using version 0.8.2

Well, have you tried my advice on how to get Alt+f2 working?

It worked, but conflicted with the same switch for Gnome, so I decided not to use it, I can use the Kommand to launch stuff as well, so I’m fine for now.

Anyway, thank a lot for all the great help, it made my opensuse back worth using it :smiley:

Simple-CCSM crashes when I try to enable Compiz. When I type xgl-switch --enable-xgl I get bash: xgl-switch: command not found. What did I miss?

If you’re using KDE 4.2.2 as your sig says, to enable compiz you should open Configure Desktop (Personal Settings) then under Personal choose Default Applications. Go down to Window Manager and choose Use a different window manager and choose compiz (not compiz custom).

Good Luck,


Interesting tip, ijbreakey! However, when I do so all window frames disappear and I can’t even move them holding down Alt, dragging with the mouse. Perhaps your advise conflicts with all of the above info in this thread? Guess I’ll try and start all over.

No, he is right but you need to configure compiz with ccsm first (move windows, resize windows and set the window decorations).