Compiz Fusion on KDE 4.2/ OpenSuse 11.1

Hi, I tried using the one-click install for Compiz-Fusion but in return I had a string of conflicts. For the record, Composite is enabled and the 3D effects are fine. Below is the conflicts list that I got (there are many more but I didn’t put them all):

#### YaST2 conflicts list - generated 2009-03-29 01:34:45 ####

nothing provides python < 2.6 needed by compizconfig-settings-manager-0.7.8-2.2.i586

     ] do not install compizconfig-settings-manager-0.7.8-2.2.i586

nothing provides python < 2.6 needed by python-compizconfig-0.7.8-2.3.i586

     ] do not install python-compizconfig-0.7.8-2.3.i586

nothing provides python < 2.6 needed by simple-ccsm-0.7.8-4.1.i586

     ] do not install simple-ccsm-0.7.8-4.1.i586

kdebase4-workspace-4.2.0-197.4.i586 requires kde4-kgreeter-plugins = 4.2.0, but this requirement cannot be provided
deleted providers: kde4-kgreeter-plugins-4.2.0-197.4.i586@System]
     ] Following actions will be done:
downgrade of kdebase4-workspace-4.2.0-197.4.i586 to kdebase4-workspace-4.1.3-10.2.1.i586
downgrade of kde4-kgreeter-plugins-4.2.0-197.4.i586 to kde4-kgreeter-plugins-4.1.3-10.2.1.i586
downgrade of kdebase4-session-4.2.0-32.2.i586 to kdebase4-session-4.1.3-2.1.i586
downgrade of kde4-kdm-4.2.0-197.4.i586 to kde4-kdm-4.1.3-10.2.1.i586
downgrade of kdebluetooth4-0.3-9.18.i586 to kdebluetooth4-0.3-4.1.1.i586
downgrade of kde4-kwin-4.2.1-3.2.i586 to kde4-kwin-4.1.3-10.2.1.i586
downgrade of kdeartwork4-screensaver-4.2.0-27.7.i586 to kdeartwork4-screensaver-4.1.3-1.26.i586
downgrade of kde4-plasmoid-quickaccess-0.7.1-6.16.i586 to kde4-plasmoid-quickaccess-0.7.1-4.22.i586
downgrade of kde4-plasma-addons-4.2.0-55.6.i586 to kde4-plasma-addons-4.1.3-5.21.i586
downgrade of kde4-kget-4.2.0-58.7.i586 to kde4-kget-4.1.3-4.13.i586
downgrade of kdebase4-runtime-4.2.1-82.2.i586 to kdebase4-runtime-4.1.3-4.1.i586
downgrade of skanlite-0.2.kde4.2.0-9.18.i586 to skanlite-0.2-3.17.i586
downgrade of ktorrent-3.2-23.1.i586 to
install (with vendor change)
  openSUSE Build Service
downgrade of kdepim4-wizards-4.2.0-89.7.i586 to kdepim4-wizards-4.1.3-3.13.i586
downgrade of kdepim4-4.2.0-89.7.i586 to kdepim4-4.1.3-3.13.i586
downgrade of kdenetwork4-filesharing-4.2.0-58.7.i586 to kdenetwork4-filesharing-4.1.3-4.13.i586
downgrade of kdegames4-4.2.0-41.17.i586 to kdegames4-4.1.3-3.8.i586
downgrade of kdemultimedia4-4.2.0-41.19.i586 to kdemultimedia4-4.1.3-4.14.i586

Please help. Appreciated!

It is not necessary to do an further install of Compiz other than that installed by default in kde4.

Thanks caf4926. Okay I had heard about it before – that there is no specific need to install compiz on this. I am just wondering-- how do I go about installing new compiz/emerald themes then? I don’t see any config manager for that on my system. That is what prompted me to do an install.


check out my post about the new one click installer on compiz. I gave a link to the old repository which works for me.

New Compiz Repositories - openSUSE Forums

For me in KDE its better to use its native effects, compiz and KDE never quite got along as its more gnome oriented.

Thanks for your response…
I am trying to install Compiz only because I need to be able to use the emerald themes. More specifically, I need to have some extra window decorations. If I am able to have that without installing Compiz I am fine with it. I have been unable to find the documentation for that. Is there a way to do it without Compiz (or as they say you dont need to install Compiz on KDE4.2).

Have a look at

Eyecandy for your KDE-Desktop -

It has plenty of themes and icons and tons of other things for your KDE desktop.

Otherwise I can try to help you get compiz working for kde. I have a specific setup that hasn’t failed me on any of the computers I’ve installed on. But the choice is yours. has plenty of themes and such to fit your needs, but if it’s not enough you can still try to get compiz to work.

Good Luck!



Thank you. I have seen the website you have mentioned and as I have mentioned in one of my previous posts, I don’t know how to go about installing the .emerald files (or the other theme) files that I can download from That is my exact problem.

Oh. Well, it’s quite easy actually. Open up emerald in a terminal with:


click import

find the file you downloaded and select it.

Emerald will then add the file to your themes.

You then just click on that theme and emerald will change to that theme.

The command “emerald-theme-manager” is not available. Here’s the output:


The program 'emerald-theme-manager' can be found in following packages:
  * compiz-emerald  path: /usr/bin/emerald-theme-manager, repository: zypp (20090215-171028) ]
  * compiz-emerald  path: /usr/bin/emerald-theme-manager, repository: zypp (repo-oss) ]
  * compiz-emerald  path: /usr/bin/emerald-theme-manager, repository: zypp (X11:XGL) ]

Try installing with: sudo zypper install compiz-emerald

bash: emerald-theme-manager: command not found

Alright…let’s make sure you’re on the same page as I am. Firstly, uninstall any compiz packages that you have.

Then follow this link Index of /repositories/X11:/XGL/openSUSE_11.1 and use compiz-kde.ymp

This will install compiz-fusion, emerald, and the fusion-icon onto your system. It might say something about failing to download plugins-main and plugins-extra.

Go into Yast Software Management and search for compiz. Re-download:

and also download compiz-fusion-plugins-extra

If you want extra themes for emerald then download

Restart your computer.

Once back in KDE, hit alt+f2 to open Krunner. Type:


and press enter.

right click on the compiz fusion icon in the system tray and make sure Compiz is selected for Select Window Manager.

Then right click on the compiz fusion icon again and under Select Window Decorator choose Emerald.

Open Configure Desktop (personal settings) (K-icon or green lizzard icon>applications>Configure Desktop)

Under Personal choose Default Applications. Click on Window Manager. For Default Component click “Use a different window manager” Choose Compiz. Not compiz custom. It will change to compiz as the windows decorator and the titlebars will disappear momentarily. Wait for them to reappear and then click accept change.

Restart your computer and compiz should be up and running by default.

Then you can open a terminal and type:


and then click import, choose the file you downloaded, and then select it for emerald to use it.

Hope this helps!


Ian, okay, give me a few minutes before I get an update on this or shoot a doubt :slight_smile: Meanwhile I tried sending you a message on ICQ, not sure you got it.
Thanks a ton for this mate.

  • A

Sounds good. I wasn’t signed in, I’m online now if you’d like to try again.

I pinged you again at ICQ, not sure if you got it. I guess it would be of much help if I could talk with you in a chat window. I am at 32632430

Not really sure how to do what you just asked me to do, so could you just add me? My icq number is 139987879

There repo for the KDE 4.2 from the factory is the one below (contains very fast Compiz version 0.8.2 )

Index of /repositories/X11:/XGL/openSUSE_11.1_KDE4_Factory

While kwin is also great but it lacks much stuff which you can find in Compiz. Be sure not to mix compiz version fromk other repo. Be sure to use ONLY 0.8.2 version. there is also simple-ccsm.

If you want to run emerald-windows then at the Configuration–>> Default Applications -->> Window Manager use Compiz. If you’ll be using emerald don’t forget to download additional themes (also from this repo) and just invoke it with Alt+F2 and typing emerald.

P.S. If you won’t have taskbars just be sure to install simple-ccsm and enable Window Decorations, Move Window and Resize Window in settings.

Good Luck!!

I have been reading forums for the last few days trying to get Compiz to work in Suse 11.1. I finally got the ATI drivers to work with the 4850HD and proceeded to work on Compiz to no avail. I found this thread. Followed the steps. Still not working. Here is where I run into a snag. When the install is done it states: The following packages could not be installed : fusion-icon. Now I have looked and the fusion-icon package IS listed in Index of /repositories/X11:/XGL/openSUSE_11.1/x86_64. So fine, I think, Ill just install it from the rpm. It doesn’t complain about it and seems to install fine. So now I have it. I right-click and load it from the krunner dialog. What I get in the task-bar is a generic icon with a red x in it. Great a broken icon or the program is borked. Any ideas why this wont load from the .ypm? Also, I notice that when playing around in ccsm i get a message say something to the effect of “Sexy python packages not installed. These are not necessary blah blah blah.” Necessary or not, which python packages is it referring?(there are like 20mil of them you know) Cause I like the sound of sexy python packages and would like to have a sexy system. Any help would be appreciated.


You don’t need the fusion-icon to enable window decorations anymore. It’s a handy tool, but this can easily be achieved by opening up the ComizConfig Settings Manager (CCSM) and under Effects there’s a plugin called Window Manager. Make sure it’s checked and then click into it. Look for “command”. Next to it, it probably says compiz-decorator. Erase that. Then type

emerald --replace

Then set compiz as your default window manager as stated by BenderBendingRodriguez.

I’m not really sure what could be wrong where it’s asking about python-sexy. But if you open Yast Software Management and search for python-sexy. You can install python-sexy. Therefore having a snakingly (that’s not a word is it?) sexy system.

Good Luck,


Cause I like the sound of sexy python packages and would like to have a sexy system.

No offense but this is one of the funniest lines I have ever come across!

Thanks for the info ijbreakey. That was very helpful.