Compiz Fusion - Edge Flipping

More desktop troubles with my new 11.0 install - On 10.3, I was able to set up edge flipping on the desktop cube so that the cube would rotate wne I moved the mouse pointer to the edge, however I don’t appear to be able to do this with the new set up.

The cube will flip when I use the keyboard shortcuts or drag either a window or an object to the side, but not when it is just the pointer on its own.

I have set up edge_flip_pointer to true in Gconf, but it still doesn’t want to play.

Does anybody have any advice/ It’s starting to annoy me, as the edge flipping cube is really useful for the way I work, and it’s slowing me down a bit now.



Have not seen a reply to this yet. Having the same problem, ie, edge flipping with pointer not working on OpenSUSE 11.0. Anyone else having the same problem?

It works for me. Do you have the “Edge Flip Pointer” box checked on the “General” tab of the “Rotate Cube” plug-in?

Yes - in apps/compiz/plugins/rotate/allscreens/options - edge_flip_pointer and edge_flip_window boxes are checked. I can rotate the cube by dragging a window, but not by bumping up against the edge with my pointer. Also under Desktop Effects have the Edges activated for flipping right and left. Still not working.


Having the same problem since 11.1
now using 11.2 milestone 2 and problem still exists

Using gnome and configured simple-ccsm correctly.


Found a way to get it working.
I opened simple-ccsm and set the edges to “nothing”
then went to ccsm and enabled “edge flippin” in the rotate cube plugin
then I disabled and enabled all other active plugins by unchecking and rechecking them again.
went back to rotate cube and found that the “edge flippin” was disabled again.
Enabled it and voila… the cube rotation works and keeps on working after reboot.

Must have something todo with the configuration of compiz.
Maybe a conflict…