Compiz error - titlebar and windows

I am a beginner in Linux. I started to use ÍKubuntu on my notebook some months ago, and just replaced it with open SUSE 11 with KDE 4 from DVD yesterday.

I tried to use the built-in compiz (did not download further packages for it) and got the following errors:

  • In the wondows’ titlebar, the close, minimize, etc. buttons disappear, and only appear again if I manage to click at the spot they should be. This happens with all windows.
  • When I have more opened windows, and I try to click on one that is in the background, somehow the window on top acts if I wouléd click that. I click on the titlebar of the bg one and I can moove the one in foreground - this totally prevents me rom click on any window except the one on top.

With Kubuntu Gutsy and KDE 3, I ran compiz-fusion on this same notebook without any error.

Asus F2HF series notebook
Celeron 1.86Ghz, 1Gb RAM
Intel 945 GM integrated Video card

I am thankful for any help!

I had this problem as well. To summarize, upgrading compiz to the latest version using the openSUSE X11:XGL community repository (YaST -> Software -> Software Repositories -> Add) should solve this issue for you.

I,also, had this problem. Thanks a million… Solution worked perfectly.

Thank you for the help!

Thought since that I cahnged back to KDE 3 till we will have a stable and well working KDE 4, and this also “solved” the problem, hehe.
I hope we will have a nice pwning KDE 4 soon…