[Compiz-CCSM] Enhanced Zoom Desktop doesn't zoom

Hi all,

It’s the first time I post in this forum.

I have installed openSUSE 11.2 in my PC. To enable compiz I have download and installed (using OneClick) the nVidia driver for my nVidia GForce 8500GT video card.

I need to enable the ‘Enhanced Zoom’ because I’m a low vision user and I need a magnifier better than Orca.

The problem is that when i try to enable it (from ccsm) there isn’t any zoom… I try to press META (or Super) and scroll with wheel (SUPER + Button 4) but nothing.

I have see that if I press Super+2 (increase zoom) the mouse pointer moves to a specific screen zone but the screen will not zoom.

Could anyone help me?



Hi all,

I tried to enable the “simple” Zoom desktop and also it doesn’t work.

I tried to google that problem and I discovered that in Ubuntu 8.10 there was the same problem posted as a bug. I think is a problemi with my video card driver (NVidia) and the integration with compiz but I haven’t idea how to fix it



I have the same problem on SLED11.

I just wonder, if you run ccsm and enable "magnifier " plug-in, will the X crash or not? In case of crashing of your X, remember to remove ~/.config/compiz directory to recover it.

you may want to have a look:
SDB:Magnifying glass in openSUSE 10.2 - openSUSE

Excuse me but I didn’t see your reply. Thanks.

No X did not crash but only the mouse change position where I tried to zoom in or out.

A note: For me it is important that all the community know this problems because are that features that make a system free and usable to all.

I solved temporally the problem… installing fedora :frowning: but this is not a solution because I want to use OpenSUSE and I can’t.



Hello people.

I had the same problem with my openSuse 11.2 and the Enhanced Zoom Desktop effect.

I solved it this way:

  1. First, I add the old openSuse 11.1 rpm repository.
    Index of /repositories/X11:/XGL/openSUSE_11.1

  2. I updated all my compiz packages to version 0.8.4-125.1 (i586)

  3. Then I restarted my computer.

  4. Finally I did execute ccsm, and activate Enhanced Zoom Desktop effect.

It did works for me, and I hope it works for you.

Hi Alberto,

Sometimes the one-click installers don’t always work, especially if you run into conflicts while installing the software. Sorry I didn’t see this thread sooner. My guess is that you probably had mixed packages, which often leads to trouble with compiz. I have an NVIDIA card as well and can use compiz without any hassles.

If you do decide to try openSUSE with compiz, please try using my step-by-step guide found here:

Installing and Configuring Compiz - openSUSE Forums

Take Care,



I try now to re-install and retry

Thanks all


Welcome back Alberto,

Make sure to read my How-To CAREFULLY and COMPLETELY. There are things you MUST do in order for the install to go as smooth as possible. If you have any problems or questions, just post in the forums.

Take Care,


I see this thread is a few months old but I’m having the same problem with opensuse 11.3. Both compiz versions from the standard repo and the X11 repo behave the same (the XGL repo doesn’t seem to exist any more). 64 bit system w/ GeForce 8800 GT and nvidia’s binaries.

Fortunately, I found the cause of this problem: https://bugzilla.novell.com/show_bug.cgi?id=641596#c7

However, If you can’t wait for updates (if there will be any), a viable workaround is to ENABLE “force independent output painting” in compizconfigmanager’s general settings.

Thank you. That deals with a particularly frustrating puzzle!


Now with a different URL
because of the transition of the wiki[1].

Is this tutorial/description still needed? The “old” wiki seems to be going to extinction.[2]


[1] http://news.opensuse.org/2010/07/12/new-wiki-what-now/
[2] http://forums.opensuse.org/english/community/opensuse-wiki-discussions/442383-what-happened-my-contributions-2.html


Thank you. That deals with a particularly frustrating puzzle![/QUOTE]

You may vote on this bugreport Bug 641596 - Desktop Zoop and Enhanced Desktop Zoom plugins do not work . Do not know if this would really speed things up but I doubt that it will make things worse :wink: .



But I now have another problem. I got compiz 0.9.0 up-and-running in KDE 4.5.1 using the kde4 window decorator (sadly had to abandon emerald), and I can configure it with ccsm, but simple-ccsm just doesn’t run. All I get is a bunch of error messages ending with a complaint that ‘compizconfig.Plugin’ object has no attribute ‘Screens’. Also, simple-ccsm-kde crashes with a segmentation fault.

The version before that did not work with the openSUSE 11.3 milestones - or at least not on all PC/graphic cards.[0]
As I know 0.9.0 is “the first unstable release of the Compiz 0.9 series”[1].
And the website for bugreports from Opencomposing gave me a “500” (Internal Server Error).[2] So maybe a bugreport in the Novell/openSUSE bugzilla of someone would be the best? As I am still using openSUSE 11.2: Someone who is using openSUSE 11.3?
http://en.opensuse.org/openSUSE:Submitting_bug_reports on the component “Compiz”?
And as Ubuntu 10.4 is using that version of compiz just a bit longer (and maybe with more users) - you may take a look at their bugreports with different words to search for[3] and and (if you find a good one) add a link to them on your openSUSE bugreport. Maybe one of them might at least be a bit alike ‘your’ bug[4]?

By the way: in this place might also a good one to find additional info on the zoom issues to add to the openSUSE bugreport on that …[5]


[0] Bug 597596 - Compiz breaks gnome desktop in oS 11.3 M5, M6
[1][compiz] Compiz 0.9.0 is Released!](http://lists.freedesktop.org/archives/compiz/2010-July/003429.html) (2010-07-04 02:12 PDT)
[2] http://bugs.opencompositing.org/
[3] Example given: Ubuntu>“compiz” package>Bugs>Search for “KDE4”
[4] Example given: kde4-window-decorator crashed with SIGSEGV in KApplication::x11EventFilter()
[5] Ubuntu>“compiz” package>Bugs>Search for “Zoom”