[compiz] can't deactivate the minimize plugin/effect

Hello,

i am trying to deactivate the minimize plugin/effect of compiz. ccsm would not let me (the checkmark disappears a moment, then appears again).

so i edited ~/.config/compiz/compizconfig/default.ini to this:


[core]
as_active_plugins = core;move;mousepoll;annotate;reflex;regex;gnomecompat;decoration;staticswitcher;crashhandler;bicubic;ring;resize;cube;resizeinfo;obs;rotate;gears;cubeaddon;
s0_hsize = 9
as_show_desktop_edge = TopLeft
s0_outputs = 1920x1080+0+0;

so, as you see, minimize is not listed. ccsm rightly reports this. still, even after restarting X, minimize is still on (and back in the config above). is there a dependency or something?

i am using openSuse 11.3 with Gnome.

linux:~> uname -r
2.6.34.7-0.4-desktop

linux:~> zypper info nvidia-gfxG02-kmp-desktop
Loading repository data...
Reading installed packages...

Information for package nvidia-gfxG02-kmp-desktop:

Repository: @System
Name: nvidia-gfxG02-kmp-desktop
Version: 260.19.12_k2.6.34.0_12-22.1
Arch: x86_64
Vendor: obs://build.suse.de/home:sndirsch:drivers
Installed: Yes
Status: up-to-date
Installed Size: 28.0 MiB
Summary: NVIDIA graphics driver kernel module for GeForce 6xxx and newer GPUs
Description: 
NVIDIA graphics driver kernel module for GeForce 6xxx and newer GPUs


linux:/var/log> zypper info compiz
Loading repository data...
Reading installed packages...


Information for package compiz:

Repository: @System
Name: compiz
Version: 0.8.6-3.4
Arch: x86_64
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 4.6 MiB
Summary: OpenGL window and compositing manager
Description: 
Compiz is an OpenGL compositing manager that use
GLX_EXT_texture_from_drawable for binding redirected top-level windows
to texture objects. It has a flexible plug-in system and it is designed
to run well on most graphics hardware.

I’m having a similar problem. I upgraded to Compiz 0.9.2, because that was what was in the separate “Compiz” repo and I’d got myself into a mess, and my processor load was always ~25% on a Core i5. I’ve just dropped back to the default version from openSUSE 11.3 in case that fixed by CPU issues and now I can’t disable the minimise effect, even if I enable Animations (it says I need to disable it, then disables it, then it comes back).