compiz as windows manager

So I installed the newest version of compiz and selected it in default
applications to be my window manager. It works but then after a few min
I loose my title bar and I have to reboot to get it back. Anyone else
run into this?

I used compiz as my window manager on 11.0 on the same pc with no
problems.

Also I noticed that none of the extra animations work when enabled.
Maybe thats whats messing it up?


jaybott

jaybott’s Profile: http://forums.opensuse.org/member.php?userid=263
View this thread: http://forums.opensuse.org/showthread.php?t=407230

Disabled animations and returned to compiz as my windows manager still
eventually lost title bar so switched back to kwin for now.

any ideas?


jaybott

jaybott’s Profile: http://forums.opensuse.org/member.php?userid=263
View this thread: http://forums.opensuse.org/showthread.php?t=407230

Same problem here. That is sooo bad because compiz is sooo much faster
than Kwin.


tleskac

tleskac’s Profile: http://forums.opensuse.org/member.php?userid=15955
View this thread: http://forums.opensuse.org/showthread.php?t=407230

I wonder if its the new nvidia driver or a change is opensuse/compiz?


jaybott

jaybott’s Profile: http://forums.opensuse.org/member.php?userid=263
View this thread: http://forums.opensuse.org/showthread.php?t=407230

I think the problem is that package compiz-kde4 is old but the new one
requires downgrade KDE to version 4.1.3. Maybe some time later…


tleskac

tleskac’s Profile: http://forums.opensuse.org/member.php?userid=15955
View this thread: http://forums.opensuse.org/showthread.php?t=407230

Solution : upgrade all compiz packages from ‘here
(http://tinyurl.com/cpeo9w)


tleskac

tleskac’s Profile: http://forums.opensuse.org/member.php?userid=15955
View this thread: http://forums.opensuse.org/showthread.php?t=407230

So I updated and now I cant even get compiz to work at all. Select it
as my default windows manager and it says it saved but kwin is still
controlling.


jaybott

jaybott’s Profile: http://forums.opensuse.org/member.php?userid=263
View this thread: http://forums.opensuse.org/showthread.php?t=407230