Compiz Animation

Hello Everyone,
I just installed opensuse 11.1, and I’m finding a really weird problem. When I activate animations in compiz (such as alt-tab ring switcher or when I move the mouse to the upper right corner and all the applications pop up) after I do a couple of switches between applications, the whole system freezes. It freezes still IN the switcher mode and I can still move my mouse but I can’t click on anything. Of course in windows I would press ctrl-alt-del but I’m new to linux and don’t know of any ‘rescue’ key combo so I end up pressing the power button until the comp shuts off.

But more importantly, what is the problem?? All other animations and everything else runs smooth (I’m running Gnome). I tried that system repair feature too with no luck. Any ideas please?

that will restart the desktop, that is if the keyboard works?!

Compiz is problematic and we would need to know more about your hardware etc…
System repair is really NOT necessary for this issue.
Compiz Fusion - openSUSE

Which desktop are you using (Gnome or KDE)? If KDE4.x, it is sensible to upgrade to KDE 4.2.x as you will find it performs better.

Have a look at this repo how to.

I have faced the same problem. In fact, it only happens when i use compiz. Kwin is quite stable.

The keyboard is non-repsonsive. I’ve tried ctrl
+alt+ backspace to no avail. it only happens when i alt-tab.

The problem got so bad, that the action alt-tab doesn’t work with compiz off. I had to uninstall compiz.

I don’t know why