Compiling Rotter

I’m new to using JACK, so bare with me…

I have jack up and running properly. That is to say I can play amarok through it…

I’m trying to install ROTTER that I found on JACK’s application website. When I try to run ./configure I get a message saying that it can not find JACK. The exact error message is this:

No package ‘jack’ found.

I know the libs are stored in /usr/lib somewhere. My question is how do I get the script to see it? Did I also mention I’m not that good at messing with the configure script?

Run ./configure --help this shows all the command line options you
probably need to add something like --jack-libdir=/usr/lib…

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 1 day 4:43, 2 users, load average: 0.22, 0.35, 0.41
GPU GeForce 8600 GTS Silent - Driver Version: 185.18.14

thnx for the reply… According to ./configure --help I should be able to do either of the following and it should work:

./configure JACK_LIBS=/usr/lib/jack
./configure JACK_CFLAGS=/usr/lib/jack
./configure PKG_CONFIG_PATH=/usr/lib/jack

But I still get the same error that it can not find it. I know I’m using 0.109.2-63.6 for jack. Here’s the exact error I’m getting

checking for JACK... configure: error: Package requirements (jack >= 0.100.0) were not met:

No package 'jack' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables JACK_CFLAGS
and JACK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Install “libjack-devel”.
The file the configure script is searching for is /usr/lib/pkgconfig/jack.pc

I created a package in the home:RedDwarf repository. Note that it requires libsndfile 1.0.18 (default openSUSE 11.1 comes with 1.0.17).

I has libsndfile formats support, including FLAC and Ogg Vorbis. I could also add MP2/MP3 support in ten seconds, but I don’t want to… one think is to provide patented formats playback support and another one is to incentive the creation of new MP3 files.

If someone wants to compile a version with MP2/MP3 support I made it easy. One only needs to pass “–with=twolame”/"–with=lame" to rpmbuild.