Compiling kernel source

I am trying to follow the information here to compile the linux kernel source. I have opensuse 11.2
Wacom USB tablet howto - openSUSE

"Get the OpenSUSE kernel sources and prepare it for external use (make oldconfig && make modules_prepare) "

when I run the above at /usr/src/linux-, I get the following error

# configuration written to .config
scripts/kconfig/conf -s arch/x86/Kconfig

*** Error during update of the kernel configuration.

make[2]: *** [silentoldconfig] Error 1
make[1]: *** [silentoldconfig] Error 2
make: *** No rule to make target `modules_prepare'.

I referred to this link

and tried running ‘make oldconfig && make prepare’

now I get a new error

scripts/kconfig/conf -s arch/x86/Kconfig

*** Error during update of the kernel configuration.

make[2]: *** [silentoldconfig] Error 1
make[1]: *** [silentoldconfig] Error 2
make: *** No rule to make target `include/config/auto.conf', needed by `include/config/kernel.release'.  Stop.

Can anyone tell me how to fix these??

I don’t think you need to compile anything for openSUSE 11.2 unless you have some very very recent hardware.

Also, the site Wacom USB tablet howto - openSUSE looks a bit outdated.

From the output of lsusb, find the vendor ID and product ID for the wacom device and check if it exists in /etc/udev/rules.d/60-wacom.rules

I do have the recent wacom tablet for which I need to compile it based on instructions here
[other] Wacom Bamboo Pen and Touch Series Development - Ubuntu Forums](

Those are all talking about old story.

What is the vendor ID, product ID of your device?

Go to my blog, you have article how to compile kernel easily.

Bus 005 Device 002: ID 056a:00d4 Wacom Co., Ltd

Thanks will check it out

Hi there,

Have you seen The Linux Wacom Project ?

Perhaps you can simply build the kernel module you need, rather than rebuilding the whole kernel? I think this might be a better route to go.

Lews Therin

That is what I am trying to follow. But I had to do an additional step for opensuse

Okay I was able to run the follwoing
Make oldconfig
Make prepare

And I compiled the Wacom source and wacom.ko was generated. Now when I try to install the module I get a module format error

insmod: error inserting ‘wacom.ko’: -1 Invalid module format

any idea??

(This was mostly just for fun, but if somone has an suggestions for compiling the linuxwacom module at the end which fails that would be great.)

Hey there,

I just tested my wife’s Wacom Bamboo and it appears to work okay with the desktop kernel and the wacom driver from the normal Yast repos, I did not have to build a new kernel module.

I played around with this though, and also took a stab at builing a new kernel module from the project, that was unable to complete the build. This is just a dump of what I did really.

Bottom line though is that my Bamboo works okay with the desktop kernel and default wacom module. If someone else get’s past the symver issue building the linuxwacom module, please let me know how you did so.

My environment:

Callandor:/ # uname -r

Callandor:~ # modprobe wacom
Callandor:~ # lsmod | grep wacom
wacom 25160 0

Callandor:~ # modinfo wacom
filename: /lib/modules/
license: GPL
description: USB Wacom Graphire and Wacom Intuos tablet driver
author: Vojtech Pavlik <>
license: GPL
description: USB Wacom Graphire and Wacom Intuos tablet driver
author: Vojtech Pavlik <>

Now, start udevadm monitor and plug in the Wacom:

Callandor:~ # udevadm monitor

KERNEL[1264779975.658774] add /devices/pci0000:00/0000:00:10.0/usb5/5-1/5-1.2 (usb)
KERNEL[1264779975.663309] add /devices/pci0000:00/0000:00:10.0/usb5/5-1/5-1.2/5-1.2:1.0 (usb)
KERNEL[1264779975.663375] add /devices/pci0000:00/0000:00:10.0/usb5/5-1/5-1.2/5-1.2:1.0/input/input7 (input)
KERNEL[1264779975.663408] add /devices/pci0000:00/0000:00:10.0/usb5/5-1/5-1.2/5-1.2:1.0/input/input7/mouse1 (input)
KERNEL[1264779975.663440] add /devices/pci0000:00/0000:00:10.0/usb5/5-1/5-1.2/5-1.2:1.0/input/input7/event3 (input)
UDEV [1264779975.739282] add /devices/pci0000:00/0000:00:10.0/usb5/5-1/5-1.2 (usb)
UDEV [1264779975.741597] add /devices/pci0000:00/0000:00:10.0/usb5/5-1/5-1.2/5-1.2:1.0 (usb)
KERNEL[1264779975.895437] add /module/joydev (module)
UDEV [1264779975.895504] add /devices/pci0000:00/0000:00:10.0/usb5/5-1/5-1.2/5-1.2:1.0/input/input7 (input)
UDEV [1264779975.914435] add /module/joydev (module)
UDEV [1264779975.975889] add /devices/pci0000:00/0000:00:10.0/usb5/5-1/5-1.2/5-1.2:1.0/input/input7/mouse1 (input)
UDEV [1264779976.024189] add /devices/pci0000:00/0000:00:10.0/usb5/5-1/5-1.2/5-1.2:1.0/input/input7/event3 (input)

This shows udev connected my tablet to, it seems, /dev/input/event3

It works, the pen moves the pointer, etc.

The following site gave some extra info on detecting and testing the tablet using wacdump:

The Linux Wacom Project
"On newer 2.6 systems, more /proc/bus/input/devices gives you

[jej@ayukawa wacom]$more /proc/bus/input/devices
I: Bus=0003 Vendor=056a Product=0042 Version=1.15
N: Name="Wacom Intuos2 6x8"
P: Phys=usb-0000:00:1d.1-2/input0
H: Handlers=event3
B: EV=1f
B: KEY=1cff 0 1f00ff 0 0 0 0 0 0 0 0
B: REL=100
B: ABS=f00017b
B: MSC=1"

I downloaded the linuxwacom-0.8.4-4 source, and ran install for the prebuilt directory which then let you use wacdump, etc:

On my system then:

Callandor:~/linuxwacom-0.8.4-4/prebuilt # wacdump /dev/input/event3
Callandor:~/linuxwacom-0.8.4-4/prebuilt # wacdump /dev/input/tablet-bamboofun-4x5

MODEL=Wacom BambooFun 4x5 ROM=1.1-3

IN_PROX=out BUTTON=+00000 (+00000 … +00000)
POS_X=+00000 (+00000 … +14760) POS_Y=+00000 (+00000 … +09225)
DISTANCE=+00000 (+00000 … +00063) PRESSURE=+00000 (+00000 … +00511)
ABSWHEEL=+00000 (+00000 … +00071) RELWHEEL=+00000 (-00001 … +00001)

LEFT=             MIDDLE=              RIGHT=              EXTRA=
SIDE=              TOUCH=             STYLUS=            STYLUS2=
 BT0=                BT1=                BT2=                BT3=
 BT4=                BT5=                BT6=                BT7=
 BT8=                BT9=               BT10=               BT11=
BT12=               BT13=               BT14=               BT15=
BT16=               BT17=               BT18=               BT19=
BT20=               BT21=               BT22=               BT23=

I don’ know why but wacdump does not update the display when you push the pen button or move it on the tablet, etc. Although the pointer moves on the screen and I can use it in Gimp, etc.

For fun I decided to try to build the kernel module for the linuxwacom project, however the symvers for my kernel, although installed, do not seem to allow the module to compile:

(This was witten for Ubuntu, so remove / change any reference to gksudo or it won’t work on Suse)

Callandor:~/wacom # python -d -c

make[2]: Entering directory /root/wacom/linuxwacom-0.8.5-9/src/2.6.27' Building linuxwacom drivers for 2.6 kernel. ***Note: Drivers not enabled as modules in your kernel config but requested through configure are NOT built make -C /lib/modules/ M=/root/wacom/linuxwacom-0.8.5-9/src/2.6.27 make[3]: Entering directory /usr/src/linux-’

WARNING: Symbol version dump /usr/src/linux-
is missing; modules will have no dependencies and modversions.

Building modules, stage 2.
MODPOST 1 modules

So it appears symvers did not like it and it didn’t build the .ko – so close . . .

Callandor:~/wacom # modinfo ./linuxwacom-0.8.5-9/src/2.6.27/wacom.o
filename: ./linuxwacom-0.8.5-9/src/2.6.27/wacom.o
license: GPL
description: USB Wacom tablet driver
author: Vojtech Pavlik <>
license: GPL
description: USB Wacom tablet driver
author: Vojtech Pavlik <>

Ahhh . . . the missing modpost error was fixed by running:

Callandor:/usr/src/linux # make scripts

(Who knew, right?)

Which created modpost so it is there when make builds the module later. That at least let me build the module successfully:

Callandor:~/linuxwacom-0.8.4-4 # make -C /lib/modules/ M=/root/wacom/linuxwacom-0.8.5-9/src/2.6.27

But, of course, it is saying it is the wrong module format. Ug.

Callandor:~/wacom # find . -iname *.ko
Callandor:~/wacom # insmod ./linuxwacom-0.8.5-9/src/2.6.27/wacom.ko
insmod: error inserting ‘./linuxwacom-0.8.5-9/src/2.6.27/wacom.ko’: -1 Invalid module format

Of course I am using a 2.6.31 kernel and the source for the linuxwacom is 2.6.27, but I would think it would build against the newer kernel source? Perhaps not.


I have the same problem. I am currently trying to compile the whole kernel by replacing the wacom files…let us see how it goes

I see there are updated packages for 11.2 available via one-click install from

I found this on the mailing list archive for the linuxwacom project: Linux Wacom Tablet Project: linuxwacom-discuss

Perhaps those packages will work for you. I am suprised your tablet is not working with the 2.6.31 kernel in suse 11.2. It is a Bamboo correct?


Yes it is a bamboo pen. I have already tried the new package and that did not work as well. Wacom Bamboo Pen Tablet: Electronics

Hopefully when my kernel has finished compiling it will work.

Oh man, I thought I was missing something as wacdump was not actually displaying any change of output, turn out you just have to run in outside of X and it works fine! Just go out to a virtual terminal and wacdump works perfectly. Good grief.

I found that out at GimpTalk • Install guide: Wacom drawing tablets with GIMP under the section “Checking that the tablet is talking correctly to the Linux operating system” I thought is was a problem with the driver or the wacdump program, but not really. It works fine really. Oh well, guess now I know.

All working okay now for me, including full pressure support, etc. in Gimp. Wow, this thing is pretty fun. Too bad I have to give it back to my wife . . . I might have to get one of these!


Wow, I am amazed the new packages did not work. If you new kernel does not work let me know, I bet we can figure it out. You can IM me if you want, my AIM name is SagoPete


Thanks for the reply. I have compiled the kernel. Now the pen is recognized but it is not very smooth. Click on pressure/tap does not work, the pen buttons for right click do not work. All I can do is move the pen on the screen and that too the mapping between tablet and screen is not correct. :’(

The below section is from:
GimpTalk • Install guide: Wacom drawing tablets with GIMP

*Setting up the configuration of the tablet in Linux

This section is mandatory in order to get the tablet to work.

So the cursor is not moving, or it’s moving and you have no pressure or tilt – it’s working mostly like a normal mouse? This is because the graphical x-server has no idea that the tablet is not a normal mouse but has all these cool features to take care of.

For this you need to configure your X-server config file. This you can find in either /etc/X11/xf86-conf or /etc/X11/xorg.conf depending on your x-server. Open this file in a text editor. Make a copy of it first, if you haven’t done this before.

Now you go to the Linux-wacom docs [here] and put in those things they tell you put in the config file, just as it says. Note the different settings depending on if your pad is connected by USB cable or not (all new tablets are).

You will add at least a “stylus” device, an “eraser” device (these are the pen tip and back tip of the pen) as well as a “cursor” device (this is the separate wacom mouse if you have it). If you have a Intuous3 there will be a “pad” device too. This is the buttons on the tablet.

Reboot the x-server. In your windows manager, you should now be able to move the mouse cursor by hovering the pen a little bit above the tablet (if you have to press down the pen to move the cursor it is not working correctly, go back to previous sections for troubleshooting). Pressing the pen down should also allow you to select, click&drag things in your window manager. If so, congrats, your pen is correctly installed. You can go to next section for some more configuration or directly to the last one to set up GIMP correctly.*

Also, try running:

wacdump /dev/input/tablet-bamboofun-4x5
(Or your tablet name)

Run this in a virtual terminal, not in gnome terminal / Konsole, but go out to a virtual terminal to run it and see if it reports input from the tablet correct.

Sorry, I had to go yesterday and couldn’t respond to your message.

Did you try the wacom module that came with openSUSE11.2?
I think it supports this device too.

Did you ever get your pen to work. Could you make what you did available as a one click download?
My new device 00d4 isn’t supported in SUSE yet either.