compiling fglrx driver for Firepro and Leap 42.1

I’ve asked the AMD support.
The answer is
The OpenSuSE Leap 42.1 is not supported yet.

You should try this:

fglrx only support kernel 3.x , work on 4.1 with patch , so the best way is read and try the link above.


I want to let you know the end of the story.

I read today in some forum that amd wants to write a unified driver (a guy who knows a guy who is working at Amd). In fact they did it! But they don’t communicate about it.

I mean that the the latest driver Crimpson Edition works perfectly with my firepro 3900. And Catalyst is catalyst pro!

So the sebastian script works fine.

If you have a firepro graphic card, it shoul work :wink:



I have read the thread and I can confirm that the crimson driver is not working for my SAPPHIRE R9 380!
Sebastian’s script works flawless no error messages, but somehow at boot the fglrx modules are not loaded.

Deinstall does not work at all, even manually removing fglrx leaves a segmentation fault of the Xserver behind.
No X.

This is a complete mess and really annoying.
Before I moved to LEAP I tried on openSuse 13,2 as well – same result!

I have filed a report on the AMD forum but many other users do have the problem.
How long will it take to get it working?

At present - I am not impressed about this.



Proprietary driver tend to use modified files in th Xstack notably the mesa stuff. reinstall mesa may bring things back. I know that you can not just remove the driver files. The Firepro cards have always been a problem since AMD does not seem to want to support them on Linux.