Because of a BUG in Audacity 2.1.1 to Audacity 2.1.3, I am trying to compile Audacity 2.1.0 on my machine.
The BUG is that you cannot change the default SAVE from .aiff to anything else and must type whatever file extension you require. Although that is not a big deal for one or two files, I have a great number of files to edit and would like to do it in as efficient manner as possible. Audacity is aware of the problem but have not found a solution to it yet. Apparently, it has to do with changing from wxWidgets 2.8.12 to wxWidgets 3.0.
In the Audacity forums, I was told that I would need to compile wxWidgets 2.8.12 as Audacity 2.1.0 would need wxWidgets 2.8.12 to run.
So far I have managed to compile wxWidgets 2.8.12.
I am trying to compile Audacity 2.1.0, but am coming up with an error at the end.
Following the advice on this page:
I checked to make sure all dependencies on their list were met.
Are there any other dependencies that opensuse would require that may not have been on the list?
I also installed all devel pkgs for these dependencies.
It has been suggested[via google] that EXPAT, glibc and glibc-devel might not be installed, but I have checked and they are.
It is shown in the code below see next post] that the compile finds wxWidgets 2.8.12 and that EXPAT is there.
This statement in the Audacity compile:
**configure: WARNING: system installation of libmad found, but it is too old. Upgrade to at least 0.14.2b to use with Audacity**
I have searched in Yast for ‘libmad’ and come up with ‘libmad0’ and its version is 1.15.1b-15.
I see no ‘libmad’.
I have gone through the Audacity compile and checked for anything missing and there are things that may be missing but they are not in repos when I search in Yast.
Where would I get them?
I see a couple of other warnings. Is it possible to identify the 1st thing that went wrong and thereby correcting it, it may correct other problems down the line?
I have run out of characters and the compile is too big also, so I will post the Audacity compile in pastebin.