Compiling Amarok 2.1 beta (2.0.96)

Hi together,

I’m trying to compile the latest amarok (2.0.96) on my opensuse box. I followed the compiling instructions and think I have all the dependencies resolved.

I’m running 11.1 with KDE 4.2 (KDE42 Repo) and installed the needed extra packages from arcticblaze

Still cmake complains, that it can’t find the qtbindings:

-----------------------------------------------------------------------------
-- The following REQUIRED packages could NOT be located on your system.
-- Please install them before continuing this software installation.
-----------------------------------------------------------------------------
+ qtscript-qt: QtScript Qt Bindings <http://code.google.com/p/qtscriptgenerator/>
-----------------------------------------------------------------------------
CMake Error at /usr/share/kde4/apps/cmake/modules/MacroLogFeature.cmake:93 (MESSAGE):
  Exiting: Missing Requirements
Call Stack (most recent call first):
  CMakeLists.txt:114 (macro_display_feature_log)

from what i can tell, qtscript is installed:


ls /usr/lib64/qt4/plugins/script/
libqtscript_core.so        libqtscript_network.so.1.0    libqtscript_svg.so.1          libqtscript_xmlpatterns.so
libqtscript_core.so.1      libqtscript_network.so.1.0.0  libqtscript_svg.so.1.0        libqtscript_xmlpatterns.so.1
libqtscript_core.so.1.0    libqtscript_opengl.so         libqtscript_svg.so.1.0.0      libqtscript_xmlpatterns.so.1.0
libqtscript_core.so.1.0.0  libqtscript_opengl.so.1       libqtscript_uitools.so        libqtscript_xmlpatterns.so.1.0.0
libqtscriptdbus.so         libqtscript_opengl.so.1.0     libqtscript_uitools.so.1      libqtscript_xml.so
libqtscript_gui.so         libqtscript_opengl.so.1.0.0   libqtscript_uitools.so.1.0    libqtscript_xml.so.1
libqtscript_gui.so.1       libqtscript_sql.so            libqtscript_uitools.so.1.0.0  libqtscript_xml.so.1.0
libqtscript_gui.so.1.0     libqtscript_sql.so.1          libqtscript_webkit.so         libqtscript_xml.so.1.0.0
libqtscript_gui.so.1.0.0   libqtscript_sql.so.1.0        libqtscript_webkit.so.1
libqtscript_network.so     libqtscript_sql.so.1.0.0      libqtscript_webkit.so.1.0
libqtscript_network.so.1   libqtscript_svg.so            libqtscript_webkit.so.1.0.0

Can anyone help me with this ? How do I tell cmake that qtbindings are installed ?

Many thanks in advance !

cheers,
Chris

cschreier wrote:

>
> Hi together,
>
> I’m trying to compile the latest amarok (2.0.96) on my opensuse box. I
> followed the compiling instructions and think I have all the
> dependencies resolved.
<snip>
fyi there’s a rpm in the playground repo
http://download.opensuse.org/repositories/KDE:/KDE4:/Playground/openSUSE_11.1_KDE_42/

Suse 11.1 x64, Kde 4.3beta, Opera 10.x weekly

many thanks ! that solves the problem.

still it would be interesting why it doesn’t compile