Compiled MadWifi for Atheros but still no wlan

Hi, Apologies in advance, I just installed openSUSE 11, am new to administering Linux, and at the moment am admittedly somewhat needy…

I successfully compiled the driver for my wired connection, so am good-to-go-there, but no luck so far with the wireless. Will try to follow the guidelines in the sticky notes, so here goes…

Hardware make/model is Atheros:

lspci-nn | egrep ‘Ethernet|Atheros’

09:00.0 Network controller [0280]: Atheros Communications Inc. Device [168c:002a] (rev 01)
0a:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101EPCI Express Fast Ethernet controller [10ec:8136] (rev 02)

dmesg yields possible error?

dmesg| egrep ‘ath|wifi|hal’

ath_hal: module license ‘Proprietary’ taints kernel.

Downloaded source from http://snapshots.madwifi-project.org/madwifi-trunk/madwifi-trunk-r3873-20081105.tar.gz and followed directions to make the modules. Everything appeared to compile OK. Did the modprobe. Let me know if you’d like me to recompile and show the output.

modinfo shows:

modinfo ath_pci

filename: /lib/modules/2.6.25.5-1.1-default/net/ath_pci.ko
license: Dual BSD/GPL
version: svn r3873
description: Support for Atheros 802.11 wireless LAN cards.
author: Errno Consulting, Sam Leffler
srcversion: 168B1DC259AAD65A2454E21
alias: pci:v0000168Cd00009013svsdbcsci*
alias: pci:v0000168Cd00000024svsdbcsci*
alias: pci:v0000168Cd00000023svsdbcsci*
alias: pci:v0000168Cd0000001Dsvsdbcsci*
alias: pci:v0000168Cd0000001Csvsdbcsci*
alias: pci:v0000168Cd0000001Bsvsdbcsci*
alias: pci:v0000168Cd0000001Asvsdbcsci*
alias: pci:v0000168Cd00000019svsdbcsci*
alias: pci:v0000168Cd00000018svsdbcsci*
alias: pci:v0000168Cd00000017svsdbcsci*
alias: pci:v0000168Cd00000016svsdbcsci*
alias: pci:v0000168Cd00000015svsdbcsci*
alias: pci:v0000168Cd0000101Asvsdbcsci*
alias: pci:v0000168Cd00001014svsdbcsci*
alias: pci:v000010B7d00000013svsdbcsci*
alias: pci:v0000A727d00000013svsdbcsci*
alias: pci:v0000168Cd00000013svsdbcsci*
alias: pci:v0000168Cd00000012svsdbcsci*
alias: pci:v0000168Cd00000007svsdbcsci*
depends: ath_hal,wlan
vermagic: 2.6.25.5-1.1-default SMP mod_unload
parm: beacon_cal:int
parm: countrycode:Override default country code. Default is 0. (int)
parm: maxvaps:Maximum VAPs. Default is 4. (int)
parm: outdoor:Enable/disable outdoor use. Default is 0. (int)
parm: xchanmode:Enable/disable extended channel mode. (int)
parm: rfkill:Enable/disable RFKILL capability. Default is 0. (int)
parm: hal_tpc:Disables manual per-packet transmit power control and lets this be managed by the HAL. Default is OFF. (int)
parm: autocreate:Create ath device in [sta|ap|wds|adhoc|ahdemo|monitor] mode. defaults to sta, use ‘none’ to disable (charp)
parm: ratectl:Rate control algorithm [amrr|minstrel|onoe|sample], defaults to ‘sample’ (charp)
parm: intmit:Enable interference mitigation by default. Default is 0. (int)
parm: ath_debug:Load-time driver debug output enable (int)
parm: ieee80211_debug:Load-time 802.11 debug output enable (int)

iwconfig is sadly lacking:

/usr/sbin/iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

lsmod| grep ath

ath_pci 262720 0
wlan 265584 1 ath_pci
ath_hal 293888 1 ath_pci

Tried rebooting, still no luck.

I have been Googling all over the internet for solutions to my issue, but haven’t found a solution yet - probably because I am making some ignorant newbie mistake.

Is the “Proprietary taints kernel” message above significant, or just an info message?

Am I missing some basic setting for the kernel to enable wireless? (I know it’s enabled in the bios, because it works fine when dual-booted to Win Vista).

Any other info I should add to help with diags, please let me know. And I sincerely appreciate any help you folks can provide!

wade-cole wrote:
> Hi, Apologies in advance, I just installed openSUSE 11, am new to
> administering Linux, and at the moment am admittedly somewhat needy…
>
> I successfully compiled the driver for my wired connection, so am
> good-to-go-there, but no luck so far with the wireless. Will try to
> follow the guidelines in the sticky notes, so here goes…
>
> Hardware make/model is Atheros:
> # lspci-nn | egrep ‘Ethernet|Atheros’
> 09:00.0 Network controller [0280]: Atheros Communications Inc. Device
> [168c:002a] (rev 01)
> 0a:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd.
> RTL8101EPCI Express Fast Ethernet controller [10ec:8136] (rev 02)
>
> dmesg yields possible error?
> # dmesg| egrep ‘ath|wifi|hal’
> ath_hal: module license ‘Proprietary’ taints kernel.

When you load a driver that has a proprietary license, you allow code that has
not been seen by the Linux community to run freely at the inner-most level of
the OS. A bug in that code may corrupt a kernel structure that shows up as a
fault in a completely different system. That is the reason the “tainted” flag is
set. The driver in question may be perfectly coded - the flag is there to warn
the developers that a problem may exist. In fact, some refuse to even comment on
a problem with a tainted kernel.

For many reasons, the madwifi project is dead. There has been considerable work
of late on the ath9k driver, which is what your device uses. You can employ the
latest by downloading and building the drivers from
http://wireless.kernel.org/en/users/Download. Building should be straight forward.

Larry

Hi Larry,

Thank you! The drivers you referred me to seem to be working! I can see other networks in the neighborhood that have WEP security. I may have to change my router (currently WPA2) to WEP if the current drivers don’t support WPA or WPA2. It’s odd that there is still so much info traffic about MadWifi when it is apparently dead, there’s even references from openSUSE. I guess word just hasn’t gotten around yet?
Anyway, thanks again, your help is greatly appreciated!

wade-cole wrote:
> Hi Larry,
>
> Thank you! The drivers you referred me to seem to be working! I can see
> other networks in the neighborhood that have WEP security. I may have to
> change my router (currently WPA2) to WEP if the current drivers don’t
> support WPA or WPA2. It’s odd that there is still so much info traffic
> about MadWifi when it is apparently dead, there’s even references from
> openSUSE. I guess word just hasn’t gotten around yet?
> Anyway, thanks again, your help is greatly appreciated!

The reason it is dead is due to the closed-source component of the driver. All
current work is being done on the open-source stuff. Within a few months, the
new drivers should be much better than madwifi.

Larry