Compaq CQ60 210TU Wireless Enable/Disable Button Not Working

Greetings to all Linux Experts!

I installed SLED 11 (and openSuse 11.1 as well) but the wireless button(WIFI ON/OFF) which is next to power button of my laptop does not work. It worked in vista (formatted the HD and installed SLED 11 as soon as I bought the notebook :wink: ) the wireless driver is Ath5k. The button should actually light up the LED and if the Wireless card is active LED should be BLUE, and ORANGE if the wireless is disabled… Now its always ORANGE! >:(

I tried to capture the hardware address of the LED but it was a failure! (previously I configured Touchpad ON/OFF switch by myself writing a small script after retrieving values from dmesg)…

So the main issue I have is WIFI On/Off switch (and LED) doesn’t work well… If somebody knows a workaround please let me know! I’m stuck!


I recently bought an ASUS X5DIJ-SX155L notebook and installed SUSE 11.2 immediately.

I need to disable the touchpad from time to time when I’m working on a text document so as not to mess up what I’ve already written by accidentally highlighting and overwriting text.

Would you know how to go about that?

Thanks a lot!

Press this button too much time it can not work at the one time i mean you should push it 3 or more times and to understand is it work or not

use this;

rfkill list