Comments on installing openSUSE 11.4

I thought I’d post these comments while the install was still fresh in my mind.

I downloaded the x86_64 dvd iso today from the GeorgiaTech mirror in the US. The 4.3 GB download took about 36 minutes. I created a bootable usb stick from the iso image with ImageWriter and installed from there.

The install proceeded normally and I chose the manual configuration option. This is my first experience at installing from a usb stick. The initial install was very fast but the configuration steps were slower than when I used a dvd disc. The default for network config is still static ip, so I had to change that setting to DHCP for both my wireless and ethernet.

I ran into an unusual difference for the firewall setting. For wireless, which I configured first, YaST offered to set the Firewall automatically. For ethernet, the default was “Firewall disabled.” I have never seen this default setting before and was wondering if it was intentional or a bug. I changed the firewall setting for ethernet to external zone.

After that, everything went smoothly. Internet test with wireless was successful and updates were installed. All the Community repos appear to be set up for 11.4. After I enabled Packman, there were multiple updates for media packages.

So far I’m impressed, but wondering about some of the default settings. I’m looking forward to hearing about other install experiences. openSUSE 11.4 looks pretty impressive!

Edit: By the way, I’m using KDE 4.6.

Smolt complains that it needs Hal running to work. Anyone else getting this after the install?

On 03/10/2011 12:06 PM, pilotgi wrote:
>
> Smolt complains that it needs Hal running to work. Anyone else getting
> this after the install?

Smolt has a packaging problem. It is known and should be fixed soon.

just upgraded from 11.4 rc2, when I would like to enable new repositories during install I don’t succeed, I had to restart, after first update suse freezed, restarted hardly, firefox hangs for seconds often, now I’m installing nvidia packages, restart and add news:-)

Not sure I understand what you are doing? Did you upgrade using “zypper dup”? If so you should enable the correct repos before you start and not “during install”. I may have misunderstood your English. :slight_smile:

I’ve upgraded from 11.3 to 11.4 using the network cd. I"m using LXDE.
I’m afraid no luck when I boot up - it just hangs on the “lizard” boot up screen and the progress bar freezes somewhere near the beginning. I tried 'failsafe" and it worked fine. I was wondering how I can fix this. No doubt there may be some log or record of the failed boot up that I can post? Tell me where I can find this. Thanks!

Richard

You could try looking through /var/log/boot.msg, it’s a plain text document.

Did you try booting in safe mode fron the Grub menu?

It could be dependant on your graphic hardware. Type:


/sbin/lspci -nnk

and look for the line with VGA in it. Then copy that line, and the next 3 lines and paste them here. That should tell us your graphic hardware.

Also, did you try booting with the boot code ‘nomodeset’ to see if that works ? It is mentioned in the openSUSE-11.4 release notes as something users could try.

The log file may be /var/log/Xorg.0.log , but it gets re-written each time you attempt a boot from the hard drive. So to get that file (and not have it written over) look for a Xorg.0.log.old file, or boot to a liveCD and copy the Xorg.0.log file associated with the failed boot.

Don’t paste the file here. If you want someone to look at it then paste it on SUSE Paste and post here the website address where that is located so volunteers like us can find it.

I’ll add a few comments here on my install experience. Perhaps this will be helpful to others.

I used the 32bit KDE live CD to install. In general, it went pretty well.

There were two glitches:

1: It messed up my system time by several hours - I’m not sure why. My previous system was set to Chicago time, with the hardware clock at UTC. I configured this one the same way. I had to adjust the time by several hours.

2: When it finished the install, it gave me a choice of rebooting now, or later. I chose later, because I know this system hangs on reboot. My plan was to do a shutdown, then a cold boot. The installer took me back to the beginning of the install menu (where it gives the Novell license). This is surely an installer bug. I hit abort (probably several times), ignored a few dire warnings that I would lose everything, and eventually got to a command line. There I could login as root and do a shutdown.

Other comments: I’m surprised at how much I still have to install over the Internet. I’m guessing I would probably be better off with the NET install CD. (I’ll try that one for my 64 bit system). Previously, I had been installing opensuse with a purchased retail DVD.

First impressions are good. But first impressions are limited. I normally use csh, and that was not there in the live CD install. That’s part of what is being installed right now, but csh was not available for my first impressions.

Here it is:

00:0d.0 VGA compatible controller [0300]: nVidia Corporation C61 [GeForce 6100 nForce 405] [10de:03d1] (rev a2)
Subsystem: Elitegroup Computer Systems Device [1019:2609]
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]

Perhaps I simply need to reinstall the nvidia driver, or update it?

Here is co

It was just a matter of adding the nvidia repository and reinstalling the graphics driver (software management) and then running nvidia-xconfig. And voila! YAST automatically found my graphics card. On the upgrade, it did say some softare could not be upgraded and would need to be added manually.

Congratulations on getting this to work.

One possibility - if you had special desktop effects enabled before the upgrade, and leave it enabled when you start the upgrade, I believe that can cause problems that can be fixed by installing the proprietary graphic driver.

I typically recommend user disable special desktop effects before updating their openSUSE.

Thanks for your comments. I will take your advise before upgrading again. Cheers.

Same problem, but i cant get to graphical unterface as failsafe either, so i cant post my info from graphics (/sbin/lspci -nnk)

too long to write down :slight_smile:

It is there with net install (and dvd probably). Live CD install is something … different. An of course, it is there on all BSDs - no matter how you install them. :wink:

Btw, seriously, bash is better.

Its easy to do from a text mode.

Install the program midnight commander. ie with root permissions:

zypper in mc 

Then as a regular user run the lspci command, redirecting the output to a text file:

/sbin/lspci -nnk > output-of-lspci.txt 

Then start midnight commander:

mc

and using the function key menus on midnight commander open the file output-of-lspci.txt and edit out everything but the lines that want to keep. (ie the line that has VGA in it and the next 2 or 3 lines).

That is not too long to write down.

And if you find it too long to write down still, then take a picture of it with your digital camera. Everyone has one of those. And post the picture on ImageBam - Fast, Free Image Hosting and Photo Sharing and post here the URL/website address where that image is located.

I’ve been using csh for over 25 years. Now is not the time to change, though I may eventually.

Downloaded 64 bit DVD. Did a clean install rather than update RC2.1. Packman and Nvidia repo’s up and working. No problems seen so far. Sound, printer and multimedia all looking good. No problems with hibernate or sleep as reported elswhere.

@consused I’m upgrading to 11.4 from 11.4RC2 via DVD, on my Dell latitude e6510 laptop, :slight_smile: it isn’t your misunderstunding but much likely my poor English :-)))
Then I installed Nvidia proprietary driver by yast and they seems to works well,
Bluetooth at first attempt, after having installed obexd-client, didn’t works,
I installed 11.4 on an external e-sata disk, although it is fst, it seems that the system hangs for 2-10 seconds sometime, mouse don’t move, dolphin don’t respond, could this dipend on the external e-sata disk install?? I think it shouldn’t, becouse e-sata data transfer-rate speed is very similar to internal sata disk.