Commented out section in evdev configuration file is still functioning


I have a HUION H610 pro tablet and have attempted to follow existing instructions on configuring the hadware buttons. In order to access the DigiMend drivers that are supposed to be compiled into the kernel, the Input section in 10-evdev.conf needs to be commented out. (And I did reboot several times after doing so).

Currently the section looks like this:
#Section “InputClass”

Identifier “evdev tablet catchall”

MatchIsTablet “on”

MatchDevicePath “/dev/input/event*”

Driver “evdev”


But examining the X11 log shows that while the Huion tablet is recognized, the evdev controller is still controlling it. What else do I need to do if changing the config file is not enough?

Thanks in advance,
Frank Alviani**

Check for more configuration files in the /etc/X11/xorg.conf.d/ directory. For example, I have 10-evdev.conf and 11-evdev.conf supplied by xorg-x11-server and xf86-input-evdev respectively (my openSUSE 13.2 system):

# rpm -qf /etc/X11/xorg.conf.d/10-evdev.conf
# rpm -qf /etc/X11/xorg.conf.d/11-evdev.conf

BTW, providing you have ‘xf86-input-libinput’ installed first, you should be able to remove ‘xf86-input-evdev’ without causing any issues.

I have a HUION H610 pro tablet and have attempted to follow existing instructions on configuring the hadware buttons.
Can you point to the instructions that you were following? That might help others to assist further.

See if the advice suggested by kriks57 helps


adding /etc/X11/xorg.conf.d/52-tablet.conf containing

Section "InputClass"
Identifier "Huion on wacom"
#    MatchIsTablet "on"
MatchProduct "HUION"
MatchDevicePath "/dev/input/event*"
Driver "wacom"

Restart the X-server with CTRL+ALT+Backspace (twice)

Check how the Huion device is reported with

xsetwacom --list

There’s some information about configuring the tablet buttons given here
This could be made persistent via an ‘autostart’ script if desired.

which instructions?
I have just bought one and it has instructions and drivers for windows and MacOS but not for linux
Opensuse 13.2


I’m not using this hardware, but check if the link in post #4 helps.

It worked with a llittle diference

andromeda:/home/fernando # xsetwacom --list
HUION PenTablet stylus                  id: 12  type: STYLUS    
HUION PenTablet eraser                  id: 13  type: ERASER    
HUION PenTablet pad                     id: 14  type: PAD       
andromeda:/home/fernando # xsetwacom --set "HUION PenTablet Pad pad" Button 1 "key +ctrl +z -z -ctrl"
Cannot find device 'HUION PenTablet Pad pad'.

That because the name of the pad is different, so this one worked

andromeda:/home/fernando # xsetwacom --set "HUION PenTablet pad" Button 1 "key +ctrl +z -z -ctrl"
andromeda:/home/fernando # 


It seems something in the process caused collateral damage.
Now I can’t mount anything from the taskbar or dolphin, I get an error and it’s nor mounted. for example, trying to mount a pendrive

An error occurred while accessing '14,9 GiB Removable Media', the system  responded: An unspecified error has occurred: Adding read ACL for uid  1001 to `/run/media/fernando' failed: Invalid argument

same error mounting a CD

fernando@andromeda:~> ls -l /run/media
total 0

I don’t see how that would be related at all. Try rebooting and check behaviour again. You can always start a new thread if required.

Did I see you create that folder in another thread?

yes, in this one, as a temporary fix while it is corrected with a patch.