command. "rm" "lsattr"

I’ve tried to delete my / tmp / directory white “rm” but without luck. I have the following with “lsattr” tried to look at the files I can not delete. but I do not understand the attribute e “e--------------. / ​​plugtmp” or whatever it is denying me access to other files

lsattr: Adgang nægtet While reading flags on ./luxh2ybf.tmp
lsattr: Adgang nægtet While reading flags on ./luxh302n.tmp
-------------e- ./plugtmp
-------------e- ./virtual-hans.7Owu4o
lsattr: Adgang nægtet While reading flags on ./luxh302e.tmp
lsattr: Adgang nægtet While reading flags on ./luxh302l.tmp
-------------e- ./hans
-------------e- ./virtual-hans.tMgFSB
-------------e- ./virtual-hans.2bdkzC
lsattr: Adgang nægtet While reading flags on ./luxh2ybd.tmp

On 02/20/2012 07:36 PM, hhbuur wrote:
> I’ve tried to delete my / tmp / directory

first, i do not believe Linux can run without a /tmp so unless it is
your purpose to kill your system, i would stop trying to remove the
directory…

second, i believe it is probably possible to learn what inside the /tmp
directory is not in use…but, i do not know offhand an easy way to
know what inside can be safely removed–so, i would (if i were you)
cease trying (i assume, you are working inside a up and running
system–if, on the other hand you have booted from a live CD and are
looking at the /tmp of a shutdown system, then everything you see in
/tmp (but NOT /tmp itself) can be deleted…

third, if you just want to make sure there is nothing in there which is
not needed then do this: ‘Clear Temp Files at Boot - openSUSE Forums’
(http://tinyurl.com/yzmzp5b)

fourth, anyway, why did you want to remove tmp?


DD http://tinyurl.com/DD-Caveat

I second DD’s remarks. And please, next time you want to show computer output to illustrate your story (which is something I love)), use CODE tags to seperate it clearly from your story text, to conserve the lay-out created by the computer program and in generaal to make it better readable: http://forums.opensuse.org/english/information-new-users/advanced-how-faq-read-only/451526-posting-code-tags-guide.html

ok I have not as written tried to delete / tmp but the contents of the directory.
why I try to delete from / tmp. I am still going through “SUSE Linux Toolbox-1000-Commands-for-opensuse-and-SUSE-Linux-Enterprise.pdf2” and reached the command “lsattr” so I’ve just tried som.

  1. it is not* / tmp*, but* /tmp* (white space is important)

  2. do not delete files in* /tmp* unless you know exectly what you do. When you want to experiment, you beter do this on a test directory (and files) within your own home directory.

  3. you may of course use lsattr, but it is specialy for attributes of files on ext2/3/4 file systems and not for the generaly used attibutes. Most people will never use it, but use ls -l .

  4. when you want to know more about *lsattr, *type:

man lsattr
  1. you will find there that it points to chattr for the meaning of the attribute letters, thus do
man chattr

for explanation about the e you see.

On Mon, 20 Feb 2012 20:16:03 +0000, hhbuur wrote:

> ok I have not as written tried to delete / tmp but the contents of the
> directory.

Install tmpwatch to do this rather than trying to use rm to do it -
tmpwatch is a much safer way to do this as it checks to see if the files
are actually being used for something and leaves them alone if they are.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

And to know why you have no access to a file, do e.g.

ls -l /tmp/plugtmp

because this gives you the owner, group and access bits of the file which lsattr doesn’t.

I guess I can not afford permission.

:~> ls -l /tmp/plugtmp
totalt 0


And also thanks for the informative answer. wg hhb

When /tmp/plugtemp is a directory, you should do:

ls -ld /tmp/plugtmp

Again, when you want to learn about a command like* ls,* do

man ls

yes i begin to see wot you are saying. and it is root permission there is requiter
i got tmpwatch install and it seems to be working, i added these line.

sudo /usr/sbin/tmpwatch -umc 1 /tmp

i doe not think that i have # /tmp/plugtemp but only # /tmp

drwxrwxrwt 19 root root 4096 21 feb 14:35 .

Well, it is nice that you begin to see what we are saying, but I am still not realy seeing what you are doing.

Except that you try to follow some document, but I have not read the document and thus do not realy know what you are doing. Only thing we did was:

a) warn you to remove things from* /tm*p without precisely knowing what you are doing. You may of course ask here to get that
knowledge, but you should tell then much, much more about your goals/problems.

b) tell you that it is the *ls *tool that tells you about ownership and access protection of files/directories and not the lsattr tool.

I realize that what the long list command to do and I have not used lsattr as an ls command
As you can see the lsattr command is just an otter exercise in the book that I read
this com From the book ”SUSE-Linux-Toolbox-1000-Commands” pages 70

Changing File Attributes
Files and directories in Linux file systems all have read, write, and execute permissions
associated with user, group, and others. However, there are also other attributes that
can be attached to files and directories that are specific to certain file system types.
Files on ext2 and ext3 file systems have special attributes that you may choose to use.
You can list these attributes with the lsattr command. Most attributes are obscure and not
turned on by default. Here’s an example of using lsattr to see some files’ attributes

   
# lsattr /etc/host* 
 -------------- /etc/host.conf 
 -------------- /etc/hosts 
 -------------- /etc/hosts.allow 
 -------------- /etc/hosts.deny 
 -------------- /etc/hosts.equiv 
 -------------- /etc/hosts.lpd 
 -------------- /etc/hosts.YaST2save 


the output from my pc is whit an “e” but e dos to my knowledge not exist as a attributes I the
man lsattr. what 1000 commands saying is that attributes can change permissions to a file or directive in a way that can not be changed on the file without first removing the attribute, and this also applies to rood rights

   

#:~> lsattr /etc/host* 
 -------------e- /etc/host.conf 
 -------------e- /etc/hosts 
 -------------e- /etc/hosts.allow 
 -------------e- /etc/hosts.deny 
 -------------e- /etc/hosts.equiv 
 -------------e- /etc/hosts.lpd 


As I told you earlier, the e is explained in the chattr man page (which is pointed to in the lsattr man page).

I am not going to read your exercise book. I can only say that almost nobody ever uses *lsattr. *Maybe you should leave that book to other times and try to use openSUSE