command "modprobe ndiswrapper" not working


I have a problem with the fritz!wlan usb stick. I have installed it with success on another PC by using instructions published here Ndiswrapper - openSUSE.

Today I have decided to erase WindowsXP from my wife’s computer (that is an identical to the one I use). So I have downloaded the OpenSuse 11.2 DVD and I have performed a completely new installation from DVD.
After installation has been executed with success, I have decided to install an internet connection using the istructions above. I told to myself: “it will take 5 minutes, all I must to do is to reply action I have done one month ago… the internet usb-stick is the same, so it will be easy to replicate the process…

I was wrong… :frowning:

When I reach the point where I must “modprobe” the ndiswrapper module I receive what follows:

linux-2n4g:/home/mila/Desktop # **modprobe ndiswrapper**
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
FATAL: Error inserting ndiswrapper (/lib/modules/ Invalid module format

Panic! :eek:

ndiswrapper seems correctly configured:

linux-2n4g:/home/mila/Desktop # **ndiswrapper -l**
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
fwlan : driver installed
	device (057C:6201) present

I receive the same message as in my working openSUSE PC…

I’m using the same version of ndiswrapper, I have installed it by the openSUSE 11.2 DVD:

ndiswrapper -v
utils version: ‘1.9’, utils version needed by module: ‘1.9’
module details:
filename: /lib/modules/
version: 1.55
vermagic: SMP mod_unload modversions 586TSC

linux-2n4g:/home/mila/Desktop # uname -r

To be honest, I see that version of the kernel is “desktop” while on my working pc is I don’t know the difference…
Using Yast, I have installed, as suggested in the istructions, the following packages:

* ndiswrapper
* ndiswrapper-kmp-default
* wireless-tools 

and all is gone ok during this steps… but I still I cannot “modprobe” the wrapper…
I’m not an expert, but seems that there is some kind of incompatibilty with the kernelkversion. In the Yast there is a package named ndiswrapper-kmp-desktop, maybe I must select that one in place of ndiswrapper-kmp-default

Any idea? :\

This can not work:

vermagic:**default** SMP mod_unload modversions 586TSC**desktop**

Using Yast, I have installed, as suggested in the istructions, the following packages:

  • ndiswrapper
  • ndiswrapper-kmp-default
  • wireless-tools

Your running kernel is “kernel-desktop”, now what do you think which ndiswrapper-kmp-something package might be the right choice?


Yes, you’re right! now the command “modprobe ndiswrapper” has worked! :slight_smile:
Excuse me, but I’m not an expert of kernel issues, looking at instructions I saw only three option listed:


So I was thinking that I MUST choose one of them… :expressionless:
I was in doubt and, before making a disaster, I have choosed to ask here in the forum…

Thanks again for your answer, now I go forward in the installation process while my wife is still waiting for her PC working… :stuck_out_tongue:

Big disaster…:frowning:

After installing


all was working fine. I have connected my PC to internet through the Fritz!wlan usb stick and I was happy.

Problems arises when I have rebooted the PC… loading-screen appears correct but after… only a black screen with the mouse in the middle! No application bar, no icons, nothing! Only a black screen…
I have tried to run openSUSE in failsafe mode but nothing to do… there are no particular errors.

I have reinstalled openSUSE for the second time, I have repeated the step to install the ndiswrapper and again… black screen…

I have installed openSUSE 11.2 for the third time and I have noticed a strange behaviour: until I not install the ndiswrapper (and the ndiswrapper-kmp-desktop) I can reboot or turn-off the system many times as I want.


if install above packages the system becames unstable (and unusable).

I think that must be something not working with the ndiswrapper packages included in the DVD rom.

Situation seems paradossal to me:

2 identical PCs,
2 identical Fritz!wlan sticks,
2 identical linux systems (openSUSE 11.2)

and one PC is unstable and the other no… :sarcastic:

The only difference is the kernel version: (for the unstable PC) (for the stable PC)

on the stable PC I have this packages installed:](

I really don’t know what can I to solve this situation… any idea?

Very simple, buy natively supported hardware and throw away this infamous AVM-junk (or sell it at $ONLINE_AUCTION_SITE or use it as a decorative new part of your fish tank if you happen to have one).

Searching different linux related fora (as you live in germany and probably understand german I would suggest, and on this hardware under recent linux distributions will tell you why.

Reasonably working WLAN cards (btw, for a desktop I would use PCI(e) and for laptops I would always prefer PCMCIA or mini-PCI(e) over USB dongles) is available for less than 30€, fighting with this AVM-stuff for hours is not worth it.

Hi akoellh,

yes, I know that the AVM stick is very close to the “pure junk” definition lol!

On the other hand… it works on the PC I’m using to write you now and I still think: “if it works on this PC, it must works on the other PC too”. I cannot understand where the problem is…:sarcastic:

I’m going to reinstall openSUSE for the 4th time… :frowning:

By the way, why the installation setup of linux always install a “desktop” kernel? How I can install a “pae” linux like on this computer?

Important news: maybe the ndiswrapper is innocent.

I have just reinstalled linux from the openSUSE dvd for the fourth time and I have experimented again that strange behaviour: after turning off and on, the user screen comes completely black.

I’ve not touched anything, I have not installed the ndiswrapper, I have done absolutely nothing… :\

So, the cause of this behaviour cannot be the installation of the ndiswrapper package.:slight_smile:

Now I have turned off and on the PC for 4 times again and it boots normally… mmmmh… I’m confused…
I’m executing a disk check using the badblocks command:

badblocks -s /dev/sda1
badblocks -s /dev/sda2
badblocks -s /dev/sda3

last command is still executing, but seems that there are no errors on the disk… if I use the fsck command, it warns me that operation could cause severe damages to the mounted filesystems :open_mouth:
Is there any other command that I can use to check disk integrity without erasing data?

On 04/07/2010 07:36 AM, giulio buccini wrote:
> Important news: maybe the ndiswrapper is innocent.

Ndiswrapper itself is innocent. It is the junk Windows driver that it
loads and gives uncontrolled access to the innermost ring that is the
problem. After you do that, you take a nice stable Linus system and give
it all the equivalents of the Blue Screens of Death seen in Windows.

Check the contents of dmesg after you load ndiswrapper. See the message
that your kernel is tainted? That is put there to let every kernel
developer know that you have loaded some piece of software into the
kernel that does not have a GPL license meaning that no one has has a
chance to review it, or even see the code. That warning also means that
developers will not attempt to debug a crash anywhere in the system as
any rogue kernel module can corrupt any kernel data structure and cause
a fault in an totally different system.