Command Line ls -l results seem wrong

in the /mnt/ folder where I am trying to mount a Windows Share I get the error of “No such file or directory”
The only difference I see is that all the other folders with successful mounts have 2 where this one has a 1
How do I change the 1 to a 2?
drw-r–r-- 1 trekjunky users 0 May 10 07:41 Shared_Folders
Thanks in advance for your help

I just read that the fifth number/character gives the number of links or directories found in the folder/file so a folder should have at least . and … but this folder only has one a corrupt folder. I guess I will try to delete then recreate it…any advice would help

Here’s my output from “ls -l”

% ls -l
total 1573385
drwxr-xr-x 1 rickert users          0 Feb  1  2013  Apps
-rw-r--r-- 1 rickert users       6488 Sep  4  2012  bootmenu.xml
-rw-r--r-- 1 rickert users     398156 Jul 25  2012  bootmgr
-rw-r--r-- 1 rickert users          1 Jun 18  2013  BOOTNXT
-rw-r--r-- 1 rickert users       6352 May 18  2017  bootsqm.dat
drwxr-xr-x 1 rickert users          0 Aug 12 05:39  Config.Msi
drwxr-xr-x 1 rickert users       4096 Feb  1  2013  DELL
-rw-r--r-- 1 rickert users      29102 Feb  1  2013  dell.sdr
lrwxrwxrwx 2 rickert users         60 Aug 22  2013 'Documents and Settings' -> /windows/C/Users
drwxr-xr-x 1 rickert users          0 Jan 31  2013  Drivers
drwxr-xr-x 1 rickert users          0 Feb  1  2013  Intel
-rw-r--r-- 1 rickert users 1342177280 Sep  2 06:21  pagefile.sys
drwxr-xr-x 1 rickert users          0 Aug 22  2013  PerfLogs
drwxr-xr-x 1 rickert users       8192 Aug 12 05:39  ProgramData
drwxr-xr-x 1 rickert users       8192 Mar 23  2017 'Program Files'
drwxr-xr-x 1 rickert users       8192 Nov 28  2016 'Program Files (x86)'
drwxr-xr-x 1 rickert users          0 Oct 25  2013  Recovery
drwxr-xr-x 1 rickert users          0 Nov 13  2013 '$Recycle.Bin'
-rw-r--r-- 1 rickert users  268435456 Sep  2 06:21  swapfile.sys
drwxr-xr-x 1 rickert users          0 Feb  1  2013 'System Recovery'
drwxr-xr-x 1 rickert users      20480 Aug 26 06:32 'System Volume Information'
drwxr-xr-x 1 rickert users          0 Feb  1  2013  Temp
drwxr-xr-x 1 rickert users       4096 Sep  5  2012 'United States Service Contracts'
drwxr-xr-x 1 rickert users       4096 Oct 25  2013  Users
drwxr-xr-x 1 rickert users      24576 Jul 18 19:25  Windows

That’s from a Windows file system (NTFS) mounted read-only.

Notice that the directories all show only “1” for the number of links. Maybe that’s a Windows thing.

I also notice that your listing did not have the ‘x’. Perhaps that comes from mount options. Directories normally need that ‘x’ to be able to access files in the directory.

Please, never forget that for mounted non-Linux file systems always a lot of faking/improviastion/etc. must be done. E.g. there are no owner/group and permissions on such a system, thus what you see is fake. Same for these links of directories, they probably do not exist on a non-linux file system and may be faked so that it works when you address them in a path, but they may not be faked as symbolic links.

Good ideas, but it is a different folder on my customer’s machine that has the x’s. I found out that when a folder is used to mount a windows share, it changes from 1 to 2, so that mystery is solved, but the problem persists. I cannot mount a Windows Share called Shared Folders (yes two words for one share) and I used /mnt/Shared\040Folders in my fstab file, but it still gives me the error “No file or directory found” or something like that as I have to come home after working on the customer’s machine. One thought I had was "Is there a limit to the number of shares mapped or the number of folders under /mnt/? So I moved the entry in the fstab file to be the first Windows Share to be mounted, but I still get the error. I have double checked the authentication and the server IP and the cifs type. I am at a loss as to the cause for this error. I have to try changing the folder name to see if the words Shared has something to do with it? I have no clue and really need a solution.
Thanks so much for looking into this. I really appreciate it.

//\040Folders /mnt/Shared\040Folders cifs username=myusername, password=mypassword, domain=mydomain 0 0

I did this from memory but I think it is 100% what I have on the system. It SHOULD work, right? Replacing myusername with the correect username, etc.

I still get the error. I haven’t changed the Windows Share name yet, should I do that?


I am not sure this works out as you hope. Where did you read that?

On a few websites. I have about 12 shares mounting AND only 1 gives me the error.

I found in

man fstab

that you can specify space and tab (otherwise field separators in fstab) as \040 and \011 for the third field (the mount point).

But that is not mentioned for the first field.

BTW, I assume that it is better to start a new thread with a good title that informs about your real problem.

I, for example, only answered here because you talk about ls -l. I know next to nothing about cifs, because I know nothing about windows. Thus if you want to draw the attention people using cifs, you better say so in the title of a thread.

Why not make it simple for you and the system and change the name into, for example, shared_folders? Now it’s one word and it is still clear it is the name you want to use.
Don’t try to beat the system cause it won’t work. Follow the rules as they have been invented.

With space in file/folder names it normally requires quotes around the names