Colors horribly displayed in Gwenview on wife's computer but not on mine

Thanks for having a look, Deano.

It remains a real mystery. :question:


Well, you can always try using the open source nouveau driver as a test I guess.

Will give that a try a.s.a.p. and let everyone know.
Thank you for the suggestion.

I always favour open source unless there’s a really compelling reason to use proprietary. Logial debugging instead of “well it works”.

However my money is on missing or version mismatch of code that is used by the Kipi software. We do not know what repositories your wife’s machine is using

zypper lr -Ed

But I am guessing nothing outlandish and including Packman. Several mpeg and jpeg libraries have come out of patent and been dropped by Packman and included in the openSUSE repositories recently.

My next suggestion:
Open a Konsole window, run

sudo zypper dup -D

It will not change anything, but answer “n” when asked for continue confirmation.
Then look at the suggestion paying special attention to jpeg and ffmpeg relted packages.
Open YaST > Software Manager in another window or Konsole tab and check out the package descriptions and verions of the Zypper suggestions starting with packages to be removed and added.

I am currently doing this on a remote Leap-42.3 machine that gets weekly YaST-On-Line-Updates. The regular uses it for statistics and uses Okular as her normal viewer, which means I do not know about Gwenview rendering. Packages of particular interest include:
ffmpeg, libswscale, libtxc_dxtn

You can ether choose to make individual changes with YaST or run “sudo zypper dup” for bulk changes (close YaST SW Manager first).

Thanks for these suggestions. I have not yet had a chance to try the open source driver yet. But I will report on all the most recent suggestions as soon as I am able to get a few minutes at wife’s computer.

Looking through the questions asked so far, I suggest that the following information be provided; both CLI commands can be executed by a “normal” user – no need for the privileges of the user “root”:

  • “zypper repos --uri --sort-by-priority”
  • “inxi -F”

For the case of ‘inxi’, after the package ‘inxi’ has been installed, execute “inxi --recommends” to determine which additional packages are needed for a more complete output of the system’s configuration and hardware.

Another thing to do is, from a “normal” user’s CLI prompt, to execute “zypper verify --details”.

Did you try renaming or deletingthe config file? /home/"the user"/.config/gwenviewec

Also make a test user see if the problem i also for that user

@gogalthorp: Refer posts #7,#8, and #9

Hello, everyone. Well my wife and I finally were successful in fixing the problem with Gwenview displaying horrible colors. But we did not achieve it in the way I would have preferred – through successful diagnosis and cure using of one or more of the many great suggestions from all of you. We tried disabling the nvidia drivers and leaving the nouveau drivers in place. That did not help. We tried going back to the nvidia drivers but that did not help. And in the process we must have done something terribly wrong as upon reboot the pooter would not give us a desktop.

Finally out of complete frustration we reinstalled Leap 42.3. A reinstall of course means we may never know the reason(s) for this mystery, but we were desperate.

As an FYI now that Gwenview is displaying properly, perhaps there might be something useful in these outputs of two of the suggested commands. This first command shows several differences between the original output shared with this list a couple of weeks ago (post #19) and this immediately below.

For the command: /usr/sbin/hwinfo --gfxcard

blonde@linux:~> /usr/sbin/hwinfo --gfxcard
29: PCI 100.0: 0300 VGA compatible controller (VGA)
[Created at pci.378]
Unique ID: VCu0.bl5nDaFS+5F
Parent ID: _Znp.mxGZ4sT7tg6
SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: “nVidia GF119 [GeForce GT 610]”
Vendor: pci 0x10de “nVidia Corporation”
Device: pci 0x104a “GF119 [GeForce GT 610]”
SubVendor: pci 0x1462 “Micro-Star International Co., Ltd. [MSI]”
SubDevice: pci 0x809f
Revision: 0xa1
Driver: “nouveau”
Driver Modules: “drm”
Memory Range: 0xfb000000-0xfbffffff (rw,non-prefetchable)
Memory Range: 0xd0000000-0xd7ffffff (ro,non-prefetchable)
Memory Range: 0xde000000-0xdfffffff (ro,non-prefetchable)
I/O Ports: 0xef00-0xef7f (rw)
Memory Range: 0xfc000000-0xfc07ffff (ro,non-prefetchable,disabled)
IRQ: 25 (60421 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v000010DEd0000104Asv00001462sd0000809Fbc03sc00i00”
Driver Info #0:
Driver Status: nouveau is active
Driver Activation Cmd: “modprobe nouveau”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #7 (PCI bridge)

Primary display adapter: #29

Where previously there were multiple references such as “nvidia” and “nvidia drm” and “nouveau is not active,” now the output shows references such as “nouveau” and “drm.”

For the command: zypper dup -D (Note: we pressed “n” and did not accept anything here)

blonde@linux:~> su -
linux:~ # zypper dup -D
Warning: You are about to do a distribution upgrade with all enabled
repositories. Make sure these repositories are compatible before you continue.
See ‘man zypper’ for more information about this command.
Loading repository data…
Reading installed packages…
Computing distribution upgrade…

The following 74 NEW packages are going to be installed:
amarok amarok-lang apparmor-abstractions apparmor-docs apparmor-parser
apparmor-profiles apparmor-utils binutils clamz digikam-doc gcc gcc48 glibc-
devel gstreamer-plugins-ugly
kernel-default-devel kernel-devel kernel-macros kio_audiocd4 libX11-6-32bit
libXau6-32bit libXext6-32bit libXvMC1 liba52-0 libasan0 libatomic1 libgpod-
lang libgpod-tools libgpod4
libitm1 libkcddb4 libkcompactdisc4 liblastfm1 libloudmouth-1-0 libmpeg2-0
libmpeg2convert0 libmpg123-0 libmygpo-qt1 libmysqld18 libnotify-tools
libpostproc53 libsidplay1 libtag-extras1
libtag_c0 libtheora0 libtsan0 libxcb1-32bit lifecycle-data-openSUSE linux-
glibc-devel normalize nvidia-computeG02 nvidia-gfxG02-kmp-default openSUSE-
patterns-openSUSE-apparmor patterns-openSUSE-apparmor_opt perl-Clone perl-
DBD-SQLite perl-DBI perl-MLDBM perl-Math-Base-Convert perl-Module-Runtime
perl-Net-Daemon perl-Params-Util
perl-PlRPC perl-RPC-XML perl-SQL-Statement perl-Term-ReadKey perl-apparmor
python3-apparmor qt4-qtscript taglib transcode unrar x11-video-nvidiaG02

The following 2 NEW patterns are going to be installed:
apparmor apparmor_opt

The following 2 packages are going to be REMOVED:
drm-kmp-default-4.9.33_k4.4.76_1-3.2 drm-kmp-default-4.9.33_k4.4.120_45-10.2

74 new packages to install, 2 to remove.
Overall download size: 132.4 MiB. Already cached: 0 B. After the operation,
additional 447.7 MiB will be used.
Continue? [y/n/…? shows all options] (y):

So again we thank everyone. We do wish that together we could have solved this mystery without a reinstall. But at least the computer is happy, Gwenview is happy, and my wife is happy. :slight_smile:

Appreciate all the thought you put into this strange Gwenview behavior.

… and I am happy :slight_smile: to see that you have it working, even though we may never know what was wrong.

Thanks for coming back to let us know.:good: