Codecs in 13.1

it seems that “one-click-install” does not install all codecs.
after a did one-click-installation, i get no support for aac+ radio streams.

Which one?
There are a few floating around.

after a did one-click-installation, i get no support for aac+ radio streams.

With which program?

Although I have no idea whether aac+ radio streams are actually supported.
Could you post a link to one such radio stream?

http://www.radioparadise.com/rp_2.php?#name=Listen

take a look on this page, the second table. you have plenty of them right there.
in fact, aac+ is a pretty popular format. it offers good quality at a lower bitrate.

now, to tell the whole story:
here is where i have got the “one-click-install” link:
http://opensuse-guide.org/codecs.php
and then, after some search, i have found a pretty large command that finally solved my issue with aac+.
this one:

zypper in libdvdcss2 vlc libxine2-codecs libxine2-pulse k3b-codecs lame gstreamer-0_10-plugins-ffmpeg gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon w32codec-all MPlayer smplayer gstreamer-0_10-plugins-good libxine2 libdvdplay0 libdvdread4 libdvdnav4 xine-ui libmad0 libavutil51 sox libxvidcore4 xvidcore libavcodec52 libavdevice52 libvlc5 lsb pullin-flash-player flash-player gstreamer-0_10-fluendo-mp3 gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good-extra k3b vlc-aout-pulse libquicktime0 gstreamer-0_10-plugins-bad-orig-addon gecko-mediaplayer

I only knew AAC, so AAC+ (also called HE-AAC) is a variant of AAC.
According to Wikipedia:

HE-AAC is supported in the open source FAAD/FAAD2 decoding library and all players incorporating it, such as VLC media player, Winamp, foobar2000, Audacious Media Player, SonicStage and Die Plattenkiste.

So what program?
I can open those AAC+ streams without problems with VLC, xine/Kaffeine, and Totem (gstreamer) and Audacious.

This link there only installs codecs for KDE (gstreamer-0_10) and xine.
So Amarok, Kaffeine and Xine should have been able to play AAC+ afterwards.

But VLC and gstreamer-1.0 (for Totem, f.e.) is missing there.

Btw, that zypper line you used installs some unneeded stuff as well.
But more importantly, vlc-aout-pulse doesn’t even exist anymore (this should only give a warning though), and vlc-codecs is missing.
So if you want to use VLC, you should still install “vlc-codecs” as well.

And you better remove w32codec-all, that’s not needed anymore for quite some time. And it doesn’t even work on a 64bit system.

You can use YaST->Software Management to add/remove packages though. You don’t have to copy/paste cryptic command lines… :wink:

thanx a lot! i am not an experienced user.
indeed, the aac+ streams work okay with vlc, but i use clementine for playing radios and clementine uses the gstreamer infrastructure.
also, mplayer works okay too. i also installed kplayer as a gui for radios…but something very strange is happening with kplayer.
when i change the station, the volume is very loud for first second and then it came to normal.
but overall, mplayer is a very good engine, i woud like to see clementine using the mplayer as sound engine, not gstreamer.

Last entry to report that ALL my multimedia formats ARE working! The vendor change is what did the trick.Thanks to everyone for their help.I’m using Totem w/Gstreamer for all my playback.This issue is successfully resolved for me.

I have tried to follow the advice for not mixing VLC and Packman Essentials and Multimedia repositories, so far with success. Also, the chromium-pepper-flash, I am told, resides in the Packman repository. So, what if I might need this flash-plugin to play correctly in chromium-browser?

if you install packman through
yast > software repositories > add > community repositories

then you will get packman in its entirety (which is really what you should have / need)

If you have packman then get rid of the VLC repo and install VLC from packman.

Then you can install pepper flash for chromium.

However, chromium will use the regular adobe flash (11.2) from the non-oss repo just fine.

I think this ability will be lost if chromium updates to v.35

Thank you for the above recommended actions. Using YaST, removed the VLC repo; then added Packman repo, as suggested. As a final test I tried Audio CD and DVD movie on a freshly rebooted system. Both of these worked fine on VLC. Thanks again!

As I said
Now chromium is up to v35
You MUST have the pepper flash plugin from Packman

Yes, chromium-pepper-flash plug-in has been installed from the Packman repository, as you have recommended; thanks again…!

YOU PEOPLE ARE LOVELY!!!
THANK YOU!!!