Codecs and notifications

Hello. I’ve installed Leap 42.1, f***ed up codecs, re-installed again, and now I’m cautious. And need your advice.
I need Totem or VLC to handle H.264, and DeadBeeF to handle mp3’s.
Sadly, neither KDE-codecs.ymp nor GNOME-codecs.ymp help me. I also do remember that last time I’ve installed openSUSE there *was *a package called “deadbeef-restricted-plugins”. And now I just can’t find it.
I also would like to mention that despite the notification-daemon is installed and running, I don’t see *any *OSDs at all! That last installation I’ve tried replacing notification-d with notify-osd package (which I’m familiar with since Lubuntu usage) and… I couldn’t figure out how to change font color or background color. So because both were set black, all I could see after running notify-send foo was a *fully *black box.

Clicking those 1 click media links is half the work as they don’t do vendor change, personally I’ve never used them, you need to add packman repo, set it as the system repo or better said do a full vendor change with packman and then install vlc, vlc-codecs etc. when you do a vendor change with packman gstramer will be pulled from packman and totem should work (I’ve never used it)
In 3 steps
#1 add packman

sudo zypper -f ar packman

#2 do a full vendor change with packman

sudo zypper dup --from packman

#3 install vlc vlc-codecs deadbeef etc.

sudo zypper in vlc vlc-codecs deadbeef --from packman

That should do it. there have been reports about some gstreamer issues
but I don’t really use gstreamer I haven’t noticed anything

I forgot to mention that I have LXDE
Btw, you meant *zypper ar -f *not zypper -f ar?

that doesn’t really matter, I use lxqt with the above steps

Btw, you meant *zypper ar -f *not zypper -f ar?

yes the -f switch means the repo should auto refresh as packman updates often you need auto-refresh on, or you will get errors.

Thanks for advising packman usage, the vendor change got me the mp3 codecs, and the vlc-codecs made h264 work
The fact I have LXDE does matter, because if I would have KDE, the KDE parts responsible for notifications would interact with notification-daemon successfully (aren’t notifications meant to be working out-of-the-box?)
LXDE lacks any notification-responsible modules, so I guess I have to use notify-osd (or any other alternative you suggest me). The problem is I have no idea how to configure OSDs’ appearance, like font color or background image

Ok I’ve finally figured it out, hope it helps someone. So if you have a combo of LXDE and openSUSE and you want to autostart apps, you just add the execution commands to /etc/lxdm/PostLogin and you’re good. BUT, if it’s kinda pre-installed and supposed-to-be-working-but-it-doesnt, you go check out lxsession-edit and look for a checkbox there.
There actually was an *unchecked by default *checkbox named “Notification service”. And it was what I needed.