Codec Problem with VLC and SMPlayer

vdpau-video shouldn’t be necessary. You should better use VDPAU directly, it should be supported by all players anyway.
And AFAIK MPlayer at least doesn’t support VA-API at all, mpv is a fork of MPlayer so it probably doesn’t either.

Probably you also have libvdpau_va_gl1 installed, which re-routes VDPAU to VA-API, and is necessary to use VDPAU on intel systems?
Together with vdpau-video this gives a nice (NOT!) endless loop…

So, uninstall libvdpau_va_gl1 and vdpau-video, and it should work. In the worst case it would only use software decoding, but it should work.

  Album_Artist: BBC TV

  Comment: Dr Amanda Foreman looks at the women behind some powerful Middle Age empires.
  Composer: BBC iPlayer

  Genre: Factual
  Title: Power
  Track: 3
 libva info: VA-API version 0.34.0
 libva info: va_getDriverName() returns 0
 libva info: Trying to open /usr/lib64/dri/nvidia_drv_video.so
 libva info: Found init function __vaDriverInit_0_34
 

This shows that you are actually using VA-API which is not supported by nvidia.

Although I have Mplayer installed (as well as mpv,) I cannot get it to run.

What does that mean?
Does MPlayer not work either, or can you not get it to work with SMPlayer?

Hi and thanks for the explanation.

I have uninstalled libvdpau_va_gl1 and vdpau-video but still no video on SMPlayer but the program is now running smoothly without glitches.

If I go to “View info & properties” button and check what is happening the dumuxer is lavf - libavformat but there is no video codec highlighted. I have tried to select lavc:h264 - H.264/AVC/MPEG-4AVC/MPEG-4 part 10 but it will not stay selected.

I do have a couple of questions. If SMPlayer is front end for both mplayer and mpv, how does it sort out which to use? Is it OK to have both installed?

AFAIAC, since mpv supersedes Mplayer2 which itself was, I understand, an enhanced fork of Mplayer, I would be happy to forget MPlayer and run with mpv but first want to get one working.

I can run mpv on its own as gui, I cannot run mplayer in console without giving it all the parameters it needs and I haven’t tried that yet through ignorance!!!

Budgie2

Hi Wolfii,
Have now run mplayer on video file from console and it runs perfectly. Here is the message it reported in console when running:-

Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 56.60.100 (external)
Mismatching header version 56.41.100
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)

Hope this helps.
Budgie2

You can configure in SMPlayer’s settings which one to use. Just select the appropriate binary, /usr/bin/mpv is the default in the openSUSE package.
And yes, it is ok to have both installed.

AFAIAC, since mpv supersedes Mplayer2 which itself was, I understand, an enhanced fork of Mplayer, I would be happy to forget MPlayer and run with mpv but first want to get one working.

MPlayer2 was an inofficial fork at some point and is an independent project (which seems to be dead now), but MPlayer also has been developed further.
I never used MPlayer2, I always sticked with the original… Not that I used it anyway though, I prefer Xine since a long time (and VLC meanwhile).

MPV is also based on MPlayer and MPlayer2, but again, it is an independent project (still active it seems), which has diverted from the original.
In the end you have to decide yourself which one you want to use though.

But I repeat: if MPV works when you run it directly but it doesn’t work via SMPlayer, there must be something wrong with the SMPlayer settings.
Again, maybe try to set a different video output. “Automatic”, if available, is probably the best choice. If that doesn’t work, try to set one f the others explicitly.

I can run mpv on its own as gui, I cannot run mplayer in console without giving it all the parameters it needs and I haven’t tried that yet through ignorance!!!

“mplayer” is a console executable without a GUI. Run “gmplayer” to have a GUI.
But SMPlayer is a “replacement GUI” anyway.

That seems to be normal. MPlayer apparently hasn’t been rebuilt against the latest ffmpeg update, but that shouldn’t cause a problem.

Hi Wolfii,
Many thanks for the further info. My preferred player for most files has been VLC for a while but occasionally it fails and I then fall back to SMPlayer, at least I did until this problem came up. I am happy to try Xine too but would like to solve present problem if only to learn a bit more about what is going on.

In summary I have both mpv and mplayer working but neither work with SMPlayer as front end, so I conclude the problem is with the SMPlayer settings.

First with mpv as underlying player, if I go to Options>Preferences in SMPlayer, the General section video tab has the video output driver as vdpau but I have tried all configuration options to no avail.

If I point SMPlayer to mplayer (/usr/bin/mplayer) I get a an error window with “SMPlayer couldn’t identify the MPlayer version you are using” It goes on “Version Reported by MPlayer, Mplayer -4.8 (C) 2000-2015 Mplayer Team” and then gives me a pull down menu with three version offered, 1.0rc1 or older, 1.0rc2 or 1.0rc3 or newer. None work!

Any suggestions as to what I should try please?
Thanks again.
Budgie2

VLC uses the same underlying libraries, and none of them should fail.
Anyway, I didn’t want to suggest what you should use, I just wanted to mention that I don’t use MPlayer or MPV. I do have MPlayer installed and it works fine as well though.

In summary I have both mpv and mplayer working but neither work with SMPlayer as front end, so I conclude the problem is with the SMPlayer settings.

Yes.
Have you tried to remove the settings completely?
I think they are in ~/.config/smplayer or similar.
Or run it on a fresh user account as a test.

Btw, there was a problem with the default audio output settings: it was set to @@DEFAULT@@ instead of pulse by mistake, which caused mpv to not start. This has been fixed since (by me… :wink: ), but existing configuration files will of course not be changed.
So check the audio output setting too, and choose either pulse or alsa.

Other than that, I would suggest to run SMPlayer from the command line and look for suspicious output.

Good call. I changed the video setting from vdpau to default and now it seems to be OK with both mpv and mplayer. I still get the error window with mplayer but if I click OK it goes away without fuss, so SMPlayer problem solved for the time being. Many thanks again.
Thanks also for the heads up on audio. Not yet had a problem there.
Regards,
Budgie2

Hm. Didn’t you write in your previous post that you tried that without effect? :\

Also, VDPAU should work if you have the nvidia driver installed (and it’s working), and libvdpau_va_gl1 is not installed.
You might play a file that your graphics card doesn’t support, but it should fall back to software decoding in that case I suppose.

Anyway, at least you got SMPlayer to work now…

I still get the error window with mplayer but if I click OK it goes away without fuss, so SMPlayer problem solved for the time being.

Apparently SMPlayer doesn’t recognize the MPlayer version. For some reason Packman’s mplayer seems to identify itself as -4.8…

# mplayer -v
MPlayer -4.8 (C) 2000-2015 MPlayer Team
...

Probably that’s why they changed the default to mpv in openSUSE’s SMPlayer package…

Possibly but whatever the reason mplayer seems to have come a long way since they wrote SMPlayer if revision numbers are anything to go by.
For the time being I am running with mpv but that does not sort out the vdpau issue. I am as sure as I can be that I have correct driver for nvidia card and that it is working OK.

PS How do you get the Quotes to appear correctly when interleaving responses? Your replies look really neat but my reply with quotes to you looks a mess?

Definitely. They are just not good in doing releases, it seems (that’s why Packman packages development snapshots since a long time). The last one was 1.1.1 2 years ago, with 1.1 being released in 2012 already.
They even state on their download page that the “latest” release is outdated. and recommend to use the development snapshots…

And it came a long way since the mplayer2 fork was created, and probably surpassed mplayer2 in every way.
I can’t say anything about mpv though.

For the time being I am running with mpv but that does not sort out the vdpau issue. I am as sure as I can be that I have correct driver for nvidia card and that it is working OK.

Maybe there’s indeed something broken in mpv’s VDPAU support, “default” instead of “vdpau” let’s mpv fall back to software decoding instead.
No idea.
I can’t even check, as I don’t have an nvidia card.

PS How do you get the Quotes to appear correctly when interleaving responses? Your replies look really neat but my reply with quotes to you looks a mess?

I add additional [noparse]

and
[/noparse] tags manually.

Hi Wolfii and thanks again. Will finish now since all is working after a fashion.
Regards,
Budgie2