Club for grub2

Grub 2 has gone stubborn on me.

It’s set to default boot to XP, but insteads boots opensuse.

Do I need a club for it. :wink:

Thanks

Whack it one for me while you are at it.:slight_smile:

Perhaps it is not set properly for the default? I have a bash script that sets the default correctly, if you want to give it a try. Read all about and download the bash script here: GNU Grub2 Command Listing Helper with --help & Input - Blogs - openSUSE Forums

Thank You,

How do you know? Please show your configuration.

Start up Yast–>System–>Boot Loader–>Click on the Boot Loader Options button.

Click on the dropdown arrow in the “Default Boot Section” field and choose “Windows XP”

Click on the OK buttons to complete.

Restart your computer.

Very nice script.

It worked like a champ.

Andy

Thanks for the other responses.

I am looking for some scripts that I can put on my desktop that will reboot or shut down the computer.

Andy

I have lots of scripts, just see my blog link in my signature. I will say that when running a desktop, it is often best to use the built-in methods to shutdown and reboot to maintain desktop settings and to not corrupt any data. And you are welcome for the Grub2Cmd script and I was very happy to help.

Thank You,

I will look for what happens using the o.s. shutdown and come up with a script that does the proper saving and cleaning up before a shutdown.

Andy