Closing boinc manager now kills boinc client

With openSUSE 15.2, closing boinc manager now kills the boinc client service running in the background and stops computations. I am using the boinc client and manager apps from openSUSE software management repos. The manager version now running is labeled as: 7.16.6. I have verified this behavior multiple times. I let boinc run continuously for month without looking at it much in the background and I don’t wish to keep the manager running. Boinc runs fine except for this issue.

With openSUSE 15.1, closing boinc manager did not kill boinc client. I racked up 1.5 million statistics points running boinc for months on 15.1 and started and stopped manager many times.

I am hoping for someone to verify this behavior on 15.2 with boinc manager version 7.16.6. This would eliminate some quirk with my system.
I am also looking for the version that ran on 15.1.
If a different boinc version, how can a replace the version I have now with the earlier version. Perhaps just put the 15.1 Main Repository repo back into my repo list temporarily to download boinc manager???
If the versions are the same, what if anything could have changed in openSUSE between 15.1 and 15.2 to change this behavior? I don’t think this to be likely but who knows.

If the 15.1 and15.2 manager versions are the same but behave differently, then I don’t see that this is an openSUSE issue and I need to take up this issue with boinc as I see it.

Any ideas? thanks

tom kosvic

Did you find a resolution to this issue? I’ve been running boinc for many years and I kept the manager running all the time. I just upgraded a drive and did a fresh install of Tumbleweed. Now, neither the boinc manager nor boinc client will run. There is an older version on the Berkely website but they tell you to use the OS package manager to install if it is in your repo. I see only this 7.16.6 version in our repo.

I am running the boinc client and boinc manager in leap with versions as downloaded from opensuse yast software management. It continuously runs as long as I don’t close manager.

For your problem, I would reinstall both boinc client and manager. This is done by setting up-arrow in software manager for each process. After this, then go to yast services and start boinc client. If you want it running all the time, set client to start on boot; not manually. I have no experience with boinc on tumbleweed, though.

Once client, is running you can monitor or change projects, etc using manager. But closing manager will still shutdown client required a restart… I have complained about this on boinc forum.

Link is:

Apparently there is some internal disagreement about manager shutting down client. It does run though.

tom kosvic

What I have done is create a user just for BOINC, with few privileges. I switch to a terminal, like Ctrl-Alt-F3, to login and run BOINC as that user. It’s easy to set a couple of config files to allow remote management.

I run the manager from my main account to control the local BOINC and the one that runs on my file server.

Sure, every time I restart the computer I have to login as that user, but it takes little time. I restart the computer only every 2-3 months, so it’s not a big deal to me.

7.16.14 is available for Leap with Experimental repo.

I tried every suggestion I could find on the web and nothing worked. But then, the Tumbleweed upgrade to 7.16.14 was available. I downloaded it and it ran as it has for the past many years. Whatever the issues were, the upgrade resolved them. This was so frustrating, I’m thinking about locking the package so it can’t upgrade. I very frequently zypper dup and the prior upgrade must have caused the problems. Also, the idea of having a BOINC-only user is interesting.

On a different note: I run “Mapping Cancer Markers” and “Open Pandemic.” The former is running much longer than previously. Most tasks were about 4 hours with some as little as 2.5 hours. There is one waiting to start that is estimated for 9.5 hours! 7 hours is now typical. I reboot a couple times a week; otherwise this pc runs constantly to crunch the tasks, so the extra time isn’t an issue just a curiosity. Has anyone else noticed this?

My system runs fine with the leap boinc version of 7.16.6 from Yast software. From my experience, I would say that your system is now running fine because of the reinstall; not due to the upgrade. Again, I have no experience with tumbleweed.

Regarding longer compute times, I would check the project website to see if they have changed the cases they are running. Their blog should say if they are moving a different direction. I think that case changes are most likely reason for the longer compute time.

I make climate prediction runs for UK Met office and some of these run 17 days each. I have 3 running now on 3 cpus. I was running 9 on 9 cpus but ran into some problems that was causing failed runs to accumulate on my disk up to 60 gig in / partition. That was excessive.

Glad to meet another boinc runner.

tom kosvic