clock widget

This is kind of stupid but for whatever reason I cannot get my digital clock widget to work. I just shows invisible like its there but just a black space where it is. If I right click on it I get the menu for it. I tried deleting it and readding it but no go. Any ideas?

Its in my taskbar but if I add one to my desktop its also just all black with no time.

Edit: More messing around, seems it just missing the time? so its just a black box with nothing in it.

(I know, this is obvious, don’t hit me …) Did you right click on the clock and select “configure?” It may be that the foreground and background colors have been set to the same value. If that doesn’t do it, what about some of the other clock styles – analog, fuzzy, etc.?

Yea I already checked that. When I right clock on the widget it always says 12:00 am. so fo whatever reason its not seeing the time. I wonder if this has anything to do with all the other icon/widget issues people are having with kde 4.2?

Ah. I don’t use 4.2, so someone else will need to answer that.

Ok so I just went into yast and said update everyhting that there is updates for. It fixed the clock widget. BUT now all my other kde settings and icons are messed up :frowning:

On to the next thing…