Clock messed up...

I don’t know what forum to put it in exactly, but it vaguely has something to do with boot so i figured here… If this is not the right sections i’m sorry, and i would ask moderators to move it…

The thing is, i probably messed up the clock somehow… I think during install.

Linux keeps messing up windows clock… And vice versa…
When the clock in windows is correct (say, 2 PM), the clock in Linux when i reboot says 4 PM… And when i set up the clock in Linux to the correct time (in this case 2 PM) and boot into windows, windows clock says 12 PM… :sarcastic:
Of course, when i correct it in windows, linux clock gets messed up again… 2 hours early or forward, idk…

I’m not sure what i did to make this happen… Maybe has something to do with hardware clock…

How can i fix this… I don’t wanna constantly correct time whenever i change systems…

If you dual boot, then you should uncheck Hardware clock is set to UTC under System > Date and Time in YaST.

Where do i uncheck it… I vaguely remember something like that being checked during install…

System > Date and Time in YaST

Hash: SHA1

open YaST, go to System -> Date and Time and press ALT+H to check or
uncheck Hardware Clock Set To UTC, then set up the clock and OK

No in elenath hîlar nan hâd gîn
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE -


Yes! That did it… I unchecked it and corrected the time, and now i’m back in windows and clock didnt get messed up! :slight_smile:

Thank you all for your help!

TO explain Windows knows only one way (and a poor one) to calcualte the time it assumes the hardware clock is set to the local time. Linux/Unix assumes the clock is set to UTC and calculates the local time based on your location. This is the much better way of doing it, especially in mobile devices that may change time zones. If you save both OS’s on the same hardware clock, it causes confusion. But Linux can be set to use local time to make Windows happy.

Knowing what time it is, is much more complicated then most people realize. :open_mouth:

Actually in the case of Windows servers that don’t have any FAT filesystems mounted, it is possible to configure them to use UTC. However once any legacy filesystems are used, it isn’t possible to use UTC. So the root cause of the problem goes all the way back to DOS, and to CP/M where the OS authors never thought beyond their local area. Unix on the other hand, was written by smart people who thought ahead.

Addendum: Also partly because DOS and CP/M didn’t originally have hardware clocks (that kept going when the machine was powered down), and then you would have to ask the user to set the UTC time, or at least configure the timezone. Most hobbyists weren’t thinking that far ahead.